Opened 7 years ago

Closed 4 years ago

#2484 closed defect (wontfix)

errant log4cplus output

Reported by: jreed Owned by:
Priority: medium Milestone: Remaining BIND10 tickets
Component: logging Version: git
Keywords: Cc:
CVSS Scoring: Parent Tickets:
Sensitive: no Defect Severity: Medium
Sub-Project: Core Feature Depending on Ticket:
Estimated Difficulty: 4 Add Hours to Ticket: 0
Total Hours: 0 Internal?: no

Description

2012-11-15 09:19:47.227 DEBUG [b10-boss.boss] BIND10_STARTED_PROCESS_PID started
 b10-auth (PID 27908)
log4cplus:ERROR LoggerImpl::getChainedLogLevel()- No valid LogLevel found
2012-11-15 09:19:47.329 INFO  [b10-auth.auth] AUTH_SERVER_CREATED server created

Subtickets

Change History (8)

comment:1 Changed 7 years ago by jinmei

What's the problem to be solved? Make sure the log4cplus error
doesn't happen? Or make sure it's not leaked into stdout/err?

comment:2 follow-up: Changed 7 years ago by jreed

This is log4cplus-1.1.0 built on NetBSD. It is built without threads due to other problem.

> config show all Logging
Logging/loggers[0]/name "*"     string  
Logging/loggers[0]/severity     "DEBUG" string  
Logging/loggers[0]/debuglevel   100     integer 
Logging/loggers[0]/additive     false   boolean (default)
Logging/loggers[0]/output_options       []      list    (default)

I have the corresponding logs around it (same time stamps) but don't have the initial log4cplus message recorded.

comment:3 Changed 7 years ago by jreed

I see another strange log message in AUTH_DATASRC_CLIENTS_SHUTDOWN_ERROR :

2012-11-15 09:29:34.755 DEBUG [b10-auth.cc] CC_DISCONNECT disconnecting from message queue daemon
2012-11-15 09:29:34.755 DEBUG [b10-auth.cc] CC_UNSUBSCRIBE unsubscribing from communication group data_sources
2012-11-15 09:29:34.755 DEBUG [b10-auth.cc] CC_GROUP_SEND sending message '{ "command": [ "stopping", { "module_name": "Auth" } ] }' to group 'ConfigManager'
2012-11-15 09:29:34.757 ERROR [b10-auth.auth] AUTH_DATASRC_CLIENTS_SHUTDOWN_ERROR error on waiting for data source builder thread: LoggerImpl::getChainedLogLevel()- No valid LogLevel found
2012-11-15 09:29:34.759 INFO  [b10-boss.boss] BIND10_LOST_SOCKET_CONSUMER consumer 16 of sockets disconnected, considering all its sockets closed
2012-11-15 09:29:34.761 INFO  [b10-boss.boss] BIND10_PROCESS_ENDED process 27908 of b10-auth ended with status 0

comment:4 in reply to: ↑ 2 Changed 7 years ago by jreed

Replying to jreed:

I have the corresponding logs around it (same time stamps) but don't have the initial log4cplus message recorded.

I was wrong. I found it in my logs as shown in the ticket description.

comment:5 Changed 7 years ago by jwright

  • Defect Severity changed from N/A to Medium
  • Milestone New Tasks deleted

comment:6 Changed 7 years ago by jelte

  • Estimated Difficulty changed from discuss to 4

comment:7 Changed 6 years ago by tomek

  • Milestone set to Remaining BIND10 tickets

comment:8 Changed 4 years ago by tomek

  • Resolution set to wontfix
  • Status changed from new to closed
  • Version set to git

Seems like boss/auth issue. No longer relevant to kea. Closing.

Note: See TracTickets for help on using tickets.