Opened 7 years ago

Closed 7 years ago

#2476 closed defect (duplicate)

DHCP libs don't build with parallel make

Reported by: vorner Owned by:
Priority: high Milestone: Sprint-DHCP-20121129
Component: dhcp Version:
Keywords: Cc:
CVSS Scoring: Parent Tickets:
Sensitive: no Defect Severity: Medium
Sub-Project: DHCP Feature Depending on Ticket:
Estimated Difficulty: 0 Add Hours to Ticket: 0
Total Hours: 0 Internal?: no

Description

There seems to be a missing dependency in the dhcp libraries somewhere. The
build succeeds with make -j1, but as I'm usually building with -j6, it
fails for me:
{{{make[5]: Entering directory `/home/vorner/work/bind10/src/lib/dhcp'

CXX libb10_dhcp_la-libdhcp++.lo
CXX libb10_dhcp
_la-iface_mgr.lo
CXX libb10_dhcp_la-iface_mgr_linux.lo
CXX libb10_dhcp
_la-iface_mgr_bsd.lo
CXX libb10_dhcp_la-option.lo
CXX libb10_dhcp
_la-iface_mgr_sun.lo
CXX libb10_dhcp_la-option6_ia.lo
CXX libb10_dhcp
_la-option_definition.lo
CXX libb10_dhcp_la-option6_iaaddr.lo
CXX libb10_dhcp
_la-option6_addrlst.lo
CXX libb10_dhcp_la-option4_addrlst.lo
CXX libb10_dhcp
_la-pkt6.lo
CXX libb10_dhcp_la-pkt4.lo
CXX libb10_dhcp
_la-duid.lo
CXX libb10_dhcpsrv_la-cfgmgr.lo
CXX libb10_dhcpsrv_la-pool.lo
CXX libb10_dhcpsrv_la-subnet.lo
CXX libb10_dhcpsrv_la-lease_mgr.lo
CXX libb10_dhcpsrv_la-memfile_lease_mgr.lo
CXX libb10_dhcpsrv_la-addr_utilities.lo

make[5]: * No rule to make target ../../../src/lib/dhcp/libb10-dhcp++.la', needed by libb10-dhcpsrv.la'. Stop.
make[5]: * Waiting for unfinished jobs....

CXX libb10_dhcpsrv_la-alloc_engine.lo

make[5]: Leaving directory `/home/vorner/work/bind10/src/lib/dhcp'
}}}

It is annoying, as it disturbs my regular workflow.

Subtickets

Change History (2)

comment:1 Changed 7 years ago by stephen

  • Milestone changed from DHCP 2012 to Sprint-DHCP-20121129

comment:2 Changed 7 years ago by stephen

  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #2475

Note: See TracTickets for help on using tickets.