Opened 7 years ago

Closed 7 years ago

#2464 closed defect (fixed)

Xfrin with TSIG broken: mistyped call

Reported by: jelte Owned by: jelte
Priority: high Milestone: Sprint-20121120
Component: xfrin Version:
Keywords: Cc:
CVSS Scoring: Parent Tickets:
Sensitive: no Defect Severity: High
Sub-Project: DNS Feature Depending on Ticket:
Estimated Difficulty: 3 Add Hours to Ticket: 0
Total Hours: 0.35 Internal?: no

Description

I was updating my public server, and one zone wasn't coming in:

2012-11-05 22:43:40.305 ERROR [b10-xfrin.xfrin] XFRIN_XFR_OTHER_FAILURE AXFR transfer of zone tjeb.nl/IN failed: 'pydnspp.TSIGContext' object has no attribute 'last_has_signature'
2012-11-05 22:43:40.316 INFO  [b10-xfrin.datasrc] DATASRC_DATABASE_UPDATER_ROLLBACK zone updates roll-backed for 'tjeb.nl./IN' on sqlite3_zone.sqlite3
2012-11-05 22:43:40.316 DEBUG [b10-xfrin.datasrc] DATASRC_DATABASE_UPDATER_DESTROYED zone updater destroyed for 'tjeb.nl./IN' on sqlite3_zone.sqlite3

From looking at the TSIGContext code, that call should not be 'last_has_signature' but 'last_had_signature'. Not sure if this is a regression due to tsig changes.

This makes all transfers fail on my system, and probably on all systems that use TSIG.

The fix is trivial (a one-letter change), but the unit tests should also be updated (a simple search-and-replace).

If possible, a unit test that would have detected this should also be added.

And we certainly need a lettuce test for this (in fact we should have already had this).

Subtickets

Change History (7)

comment:1 Changed 7 years ago by jelte

  • Estimated Difficulty changed from 0 to 3

comment:2 Changed 7 years ago by jelte

  • Defect Severity changed from N/A to High
  • Milestone changed from New Tasks to Sprint-20121120

comment:3 Changed 7 years ago by jelte

  • Owner set to jelte
  • Status changed from new to assigned

comment:4 Changed 7 years ago by jelte

  • Owner changed from jelte to UnAssigned
  • Status changed from assigned to reviewing

Ready for review, actual code changes are quite small (so it is mostly the lettuce test, which I hope is pretty self-explanatory)

comment:5 Changed 7 years ago by vorner

  • Owner changed from UnAssigned to vorner

comment:6 Changed 7 years ago by vorner

  • Owner changed from vorner to jelte
  • Total Hours changed from 0 to 0.35

The code looks OK and ready for merge.

But, did we have this code in any release? If so, there should be a changelog entry for it.

comment:7 Changed 7 years ago by jelte

  • Resolution set to fixed
  • Status changed from reviewing to closed

Thanks, I added a changelog entry.

Merged, closing ticket.

Note: See TracTickets for help on using tickets.