Opened 7 years ago

Closed 7 years ago

#2363 closed defect (duplicate)

regression: b10-auth cannot get the default data_sources config

Reported by: jinmei Owned by:
Priority: high Milestone: Sprint-20121106
Component: b10-auth Version:
Keywords: Cc:
CVSS Scoring: Parent Tickets:
Sensitive: no Defect Severity: High
Sub-Project: DNS Feature Depending on Ticket:
Estimated Difficulty: 0 Add Hours to Ticket: 0
Total Hours: 0 Internal?: no

Description

I'm afraid I introduced a regression in #2203 at commit
c91bffdd00deb8b7f3ceda9954a84e31c0cfb9f1.

If b10-auth runs with the default data_sources configuration, it now
misses it. I suspect this is because at the time of call to
getRemoteConfigValue() from datasrcConfigHandler(), the underlying cc
module still doesn't get the default. Previously we called
getRemoteConfigValue() after the completion of getRemoteConfig()
so it worked correctly.

Fix shouldn't be difficult, but we should probably also include #2361
for this task.

Based on a jabber discussion I'm pushing this to the current sprint.

Subtickets

Change History (4)

comment:1 Changed 7 years ago by jreed

  • Defect Severity changed from N/A to High
  • Priority changed from medium to high

comment:2 Changed 7 years ago by jinmei

I've addressed this issue in #2211. Hopefully #2211 can be merged by the end of
the sprint, in which case we can simply close this ticket, too.

comment:3 Changed 7 years ago by jinmei

#2211 has been merged with the fix to this problem. Closing this ticket too.

comment:4 Changed 7 years ago by jinmei

  • Resolution set to duplicate
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.