Opened 7 years ago

Closed 7 years ago

#2273 closed defect (duplicate)

in-memory load should allow RRSIG without covered RRset

Reported by: jinmei Owned by:
Priority: medium Milestone:
Component: data source Version:
Keywords: Cc:
CVSS Scoring: Parent Tickets:
Sensitive: no Defect Severity: N/A
Sub-Project: DNS Feature Depending on Ticket:
Estimated Difficulty: 5 Add Hours to Ticket: 0
Total Hours: 0 Internal?: no

Description

In #2267 I noticed the new in-memory zone loader doesn't support
the case where RRSIG is added without having the corresponding
covered RRset. It's almost a broken setup, but I actually intended to
allow such cases originally. That may become a more practical issue
when we support incremental updates (after IXFR-in or DDNS), where
there may be some intermediate state that only RRSIGs are added first
and we cannot predict whether/when the covered RRset comes.

But I didn't support that case in #2267 because from a quick look it
would break some assumption in the finder implementation.

So this ticket will fix both the loader and the finder:

  • the loader just allows this case. It should be an easy update to InMemoryClient::Loader class (of #2267).
  • handle this case in the finder. If, for example, a lookup of example.com/A results in an RRSIG-only rdataset (which covers type A), it should return NXRRSET.

Subtickets

Change History (3)

comment:1 Changed 7 years ago by muks

  • Estimated Difficulty changed from 0 to 5

comment:2 Changed 7 years ago by jinmei

It's a duplicate of #2420.

comment:3 Changed 7 years ago by jinmei

  • Resolution set to duplicate
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.