Opened 7 years ago

Closed 7 years ago

#2266 closed defect (fixed)

remove RRsetList class

Reported by: jinmei Owned by: muks
Priority: medium Milestone: Sprint-20121023
Component: libdns++ Version:
Keywords: Cc:
CVSS Scoring: Parent Tickets:
Sensitive: no Defect Severity: N/A
Sub-Project: DNS Feature Depending on Ticket:
Estimated Difficulty: 3 Add Hours to Ticket: 0
Total Hours: 0 Internal?: no

Description

i.e., just remove lib/dns/rrsetlist.h,cc and its tests.

As far as I know the old data source implementation is the only user
of this class, and the class interface is (IMO) quite confusing. It's
better gone.

Depend on #2161.

Subtickets

Change History (10)

comment:1 Changed 7 years ago by jinmei

  • Milestone set to Next-Sprint-Proposed

comment:2 Changed 7 years ago by jelte

  • Milestone changed from Next-Sprint-Proposed to Sprint-20121009

we ran out of tickets, moving this one to current sprint (if not taken at sprint planning we can re-discuss then)

comment:3 Changed 7 years ago by muks

  • Owner changed from UnAssigned to muks
  • Status changed from new to assigned

Picking.

comment:4 Changed 7 years ago by muks

  • Owner changed from muks to UnAssigned
  • Status changed from assigned to reviewing

Up for review.

comment:5 Changed 7 years ago by jinmei

Changes look okay. If not done, please confirm it doesn't break make
distcheck. Adding or deleting files often cause such regression.

Also, I wonder we might want to provide changelog, because
technically this is a change to the public API.

comment:6 Changed 7 years ago by jinmei

  • Owner changed from UnAssigned to muks

comment:7 follow-up: Changed 7 years ago by muks

  • Owner changed from muks to jinmei

ChangeLog entry:

+XXX.   [func]          muks
+       The isc::dns::RRsetList class has been removed. It was unused
+       inside the BIND 10 codebase.
+       (Trac #2266, git ...)

make distcheck passes.

comment:8 in reply to: ↑ 7 Changed 7 years ago by jinmei

Replying to muks:

ChangeLog entry:

+XXX.   [func]          muks
+       The isc::dns::RRsetList class has been removed. It was unused
+       inside the BIND 10 codebase.
+       (Trac #2266, git ...)

Just saying "unused" may be weak. In the case of public API, I think
it's possible (in theory) that we publish it even if we don't use it
internally. So I suggest something like this:

XXX.   [func]          muks
       The isc::dns::RRsetList class has been removed. It was now unused
       inside the BIND 10 codebase, and the interface was considered
       prone to misuse.
       (Trac #2266, git ...)

make distcheck passes.

Okay, then please merge (unless you want to discuss changelog wording
more).

comment:9 Changed 7 years ago by jinmei

  • Owner changed from jinmei to muks

comment:10 Changed 7 years ago by muks

  • Resolution set to fixed
  • Status changed from reviewing to closed

Merged to master:

* 5fadea6 [2266] Update ChangeLog
* 9a9260c [2266] Remove all traces of RRsetList

Resolving as fixed. Thank you for the reviews Jinmei.

Note: See TracTickets for help on using tickets.