Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#2248 closed defect (duplicate)

FATAL [b10-auth.auth] AUTH_SERVER_FAILED logged twice

Reported by: jreed Owned by:
Priority: medium Milestone:
Component: Unclassified Version:
Keywords: Cc:
CVSS Scoring: Parent Tickets:
Sensitive: no Defect Severity: N/A
Sub-Project: DNS Feature Depending on Ticket:
Estimated Difficulty: 3 Add Hours to Ticket: 0
Total Hours: 0 Internal?: no

Description

See https://lists.isc.org/pipermail/bind10-users/2012-September/000393.html

2012-09-03 16:03:18.873 FATAL [b10-auth.auth] AUTH_SERVER_FAILED server
failed: RRSIG is being added, but no RR of covered type found: as34288.net.
7200 IN RRSIG SSHFP 7 2 7200 20120917042044 20120831011030 43405 as34288.net.
zWGqGQr5AxLdZdX7+Xx6lwGGyBmT/jOR6H11ZXQ2/Qogv5zh86KO2x0XxnhCDSSSkQkAbVDNTqgx+u
WVtaz10X8/BJXiAzJUOLGAB/iLKvPPI5tI2PJuTYfONy7LytWBkrSMmihUJcBXdmGKdNJ2edql6Y7PkX
+z4deKSB9imF0=

...

2012-09-03 16:03:18.875 FATAL [b10-auth.auth] AUTH_SERVER_FAILED server
failed: RRSIG is being added, but no RR of covered type found: as34288.net.
7200 IN RRSIG SSHFP 7 2 7200 20120917042044 20120831011030 43405 as34288.net.
zWGqGQr5AxLdZdX7+Xx6lwGGyBmT/jOR6H11ZXQ2/Qogv5zh86KO2x0XxnhCDSSSkQkAbVDNTqgx+u
WVtaz10X8/BJXiAzJUOLGAB/iLKvPPI5tI2PJuTYfONy7LytWBkrSMmihUJcBXdmGKdNJ2edql6Y7PkX
+z4deKSB9imF0=

Why is this logged twice?

Subtickets

Change History (4)

comment:1 Changed 7 years ago by muks

Maybe it tried to load the zone file twice, or it has two such records, or something else. :)

It should be easy to fix and taken care of by #2247.

comment:2 Changed 7 years ago by vorner

Aren't you starting two auth servers?

comment:3 Changed 7 years ago by jreed

  • Resolution set to duplicate
  • Status changed from new to closed

It is acting like two auth servers are being ran:

2012-09-03 16:03:18.771 DEBUG [b10-auth.datasrc] DATASRC_SQLITE_NEWCONN
SQLite3Database is being initialized
2012-09-03 16:03:18.771 DEBUG [b10-auth.datasrc] DATASRC_SQLITE_CONNOPEN
Opening sqlite database file '/opt/bind10/var/bind10-devel/zone.sqlite3'
2012-09-03 16:03:18.771 DEBUG [b10-auth.datasrc] DATASRC_SQLITE_NEWCONN
SQLite3Database is being initialized
2012-09-03 16:03:18.771 DEBUG [b10-auth.datasrc] DATASRC_SQLITE_CONNOPEN
Opening sqlite database file '/opt/bind10/var/bind10-devel/zone.sqlite3'
...
2012-09-03 16:03:18.875 DEBUG [b10-auth.cc] CC_DISCONNECT disconnecting from
message queue daemon
2012-09-03 16:03:18.875 DEBUG [b10-auth.cc] CC_DISCONNECT disconnecting from
message queue daemon

(This is from an off-list email sent to me by the original reporter.)
Now I see the second component:

2012-09-03 16:03:18.876 DEBUG [b10-boss.boss] BIND10_CONFIGURATOR_BUILD
building plan '{'b10-stats': ({'kind': 'dispensable', 'address': 'Stats'},
<isc.bind10.component.Component object at 0x7fa609083590>), 'cfgmgr':
({'kind': 'core', 'special': 'cfgmgr', 'priority': 198},
<isc.bind10.special_component.CfgMgr object at 0x7fa609b0d2d0>),
'b10-zonemgr': ({'kind': 'needed', 'priority': 10},
<isc.bind10.component.Component object at 0x7fa6090839d0>), 'b10-xfrin':
({'kind': 'needed', 'priority': 10}, <isc.bind10.component.Component object
at 0x7fa609083450>), 'b10-cmdctl': ({'kind': 'needed', 'special': 'cmdctl'},
<isc.bind10.special_component.CmdCtl object at 0x7fa60906a790>),
'sockcreator': ({'kind': 'core', 'special': 'sockcreator', 'priority': 200},
<isc.bind10.special_component.SockCreator object at 0x7fa609b0d350>),
'msgq': ({'kind': 'core', 'special': 'msgq', 'priority': 199},
<isc.bind10.special_component.Msgq object at 0x7fa609b0d310>), 'b10-auth-0':
({'kind': 'needed', 'special': 'auth', 'priority': 10},
<isc.bind10.special_component.Auth object at 0x7fa609083a10>), 'b10-auth-1':
({'kind': 'needed', 'special': 'auth', 'priority': 10},
<isc.bind10.special_component.Auth object at 0x7fa609083a50>)}' -> '{}'

So my real problem was much of the logging was just "b10-auth" and no indication it was b10-auth-0 versus b10-auth-1.

This is a duplicate of #2177.

comment:4 Changed 7 years ago by shane

  • Milestone New Tasks deleted
Note: See TracTickets for help on using tickets.