Opened 7 years ago

Closed 5 years ago

#2243 closed defect (wontfix)

what is "no module_name in module_spec"?

Reported by: jreed Owned by:
Priority: medium Milestone: Remaining BIND10 tickets
Component: ddns Version: bind10-old
Keywords: Cc:
CVSS Scoring: Parent Tickets:
Sensitive: no Defect Severity: N/A
Sub-Project: DNS Feature Depending on Ticket:
Estimated Difficulty: 4 Add Hours to Ticket: 0
Total Hours: 0 Internal?: no

Description

I restarted all of bind10 master; my previous configuration was from a June instance.

2012-09-06 08:10:55.840 WARN  [b10-ddns.ddns] DDNS_GET_REMOTE_CONFIG_FAIL failed
 to get Zonemgr module configuration 1 times: no module_name in module_spec
2012-09-06 08:10:56.846 WARN  [b10-ddns.ddns] DDNS_GET_REMOTE_CONFIG_FAIL failed
 to get Zonemgr module configuration 2 times: no module_name in module_spec
2012-09-06 08:10:57.856 WARN  [b10-ddns.ddns] DDNS_GET_REMOTE_CONFIG_FAIL failed
 to get Zonemgr module configuration 3 times: no module_name in module_spec
2012-09-06 08:10:58.865 ERROR [b10-ddns.ddns] DDNS_MODULECC_SESSION_ERROR error 
encountered by configuration/command module: no module_name in module_spec

This loops.

What is no "module_name in module_spec"? It doesn't tell me what to fix so I can get it running again.

Also the last ERROR should be FATAL, since the process ends.

Subtickets

Change History (7)

comment:1 Changed 7 years ago by jinmei

it won't be very hard to address this particular point in some
ad hoc way. But in my gut feeling this is a tip of iceberg and should
rather be solved based on a generic framework of error handling in
configuration.

comment:2 Changed 7 years ago by shane

I agree that it should be straightforward to solve in an ad hoc way (like print the filename being opened?). I'm not sure it is a larger problem in general, but I admit it could be!

comment:3 Changed 7 years ago by jelte

Actually, the problem appears to be that auth is not (yet) running. At least, this behaviour (also) occurs when auth is not running. Whether or not this is related to a more fundamental change in messaging/config, this appears to be a regression that should be handled (or at least fail more clearly).

comment:4 Changed 7 years ago by jelte

Err, Zonemgr, not auth, but same problem.

comment:5 Changed 7 years ago by shane

  • Milestone New Tasks deleted

comment:6 Changed 6 years ago by tomek

  • Milestone set to Remaining BIND10 tickets

comment:7 Changed 5 years ago by tomek

  • Resolution set to wontfix
  • Status changed from new to closed
  • Version set to old-bind10

This issue is related to bind10 code that is no longer part of Kea.

If you are interested in BIND10/Bundy framework or its DNS components,
please check http://bundy-dns.de.

Closing ticket.

Note: See TracTickets for help on using tickets.