Opened 7 years ago

Closed 6 years ago

#2227 closed defect (wontfix)

re-add a temporary hotspot cache

Reported by: jreed Owned by:
Priority: medium Milestone:
Component: data source Version:
Keywords: Cc:
CVSS Scoring: Parent Tickets:
Sensitive: no Defect Severity: High
Sub-Project: DNS Feature Depending on Ticket:
Estimated Difficulty: meta Add Hours to Ticket: 0
Total Hours: 0 Internal?: no

Description

ChangeLog? 455 (I think) removed the existing hot spot cache mechanism.

Attached to this ticket is a graph showing a drop after when the default hotcache was removed. I mark this ticket as a defect (versus a task or feature) due to this performance regression.

It is useful in case of huge external databases that cannot be loaded into in-memory.

vorner suggested: I think an query-answer cache (with rendered response packets) would make more sense.

Subtickets

Attachments (1)

smallzone-sqlite.png (5.1 KB) - added by jreed 7 years ago.
QPS for small sqlite3 database for 2012 snapshots

Download all attachments as: .zip

Change History (5)

Changed 7 years ago by jreed

QPS for small sqlite3 database for 2012 snapshots

comment:1 Changed 7 years ago by jinmei

I personally think we should clarify requirements, or at the very
least try to gather such information. See #2228.

comment:2 Changed 7 years ago by shane

  • Milestone New Tasks deleted

comment:3 Changed 7 years ago by jreed

  • Milestone set to Next-Sprint-Proposed

comment:4 Changed 6 years ago by tomek

  • Resolution set to wontfix
  • Status changed from new to closed

Kea project is DHCP only. Closing stale DNS-related tickets.

If you're interested in DNS, please see Bundy project http://bundy-dns.de

Note: See TracTickets for help on using tickets.