Opened 7 years ago

Closed 5 years ago

#2192 closed defect (wontfix)

look into openbsd socket error

Reported by: jinmei Owned by:
Priority: medium Milestone: Remaining BIND10 tickets
Component: ~Inter-module communication(obsolete) Version: bind10-old
Keywords: Cc:
CVSS Scoring: Parent Tickets:
Sensitive: no Defect Severity: N/A
Sub-Project: Core Feature Depending on Ticket:
Estimated Difficulty: 8 Add Hours to Ticket: 0
Total Hours: 0 Internal?: no

Description

See this
http://git.bind10.isc.org/~tester/builder/BIND10/20120815131128-OpenBSD5-amd64/logs/unittests.out

This happens periodically, and the only effective workaround seems to
be to reboot the machine.

It looks like a kernel bug, but we are not very sure about that.
We should at least figure out (if possible) a simpler way to reproduce
the problem. My guess is that if we repeat forwarding FDs via unix
domain sockets some resource leaks in the kernel and it eventually
triggers the problem.

Subtickets

Change History (9)

comment:1 Changed 7 years ago by jinmei

  • Milestone changed from New Tasks to Next-Sprint-Proposed

comment:2 Changed 7 years ago by jreed

As a workaround, I often raised kern.maxclusters

I emailed openbsd lists about this issue.

But problem still happens later. I now exclude the ForwardTest?.connect test on the openbsd system.

comment:3 Changed 7 years ago by jinmei

We've not seen this for a while. Not sure if it's because of kernel update
or something, but maybe we can close it for now?

comment:4 Changed 7 years ago by jinmei

  • Milestone set to Next-Sprint-Proposed
  • Priority changed from medium to high

comment:5 Changed 7 years ago by jreed

The builder was excluding ForwardTest?.connect:ForwardTest.pushAndPop:ForwardTest.badPush:ForwardTest.pushTooFast:ForwardTest.badPop since October. I now removed this exclusion to see if problem still happens.

(By the way, the same system still excludes -IfaceMgrTest?.sendReceive6 -- see #1824.)

comment:6 Changed 7 years ago by jinmei

  • Priority changed from high to medium

comment:7 Changed 7 years ago by shane

How long do we need to wait to see if the problem happens? (Given that it's been 9 days, and we don't seem to be in this state yet.)

comment:8 Changed 6 years ago by tomek

  • Milestone set to Remaining BIND10 tickets

comment:9 Changed 5 years ago by tomek

  • Resolution set to wontfix
  • Status changed from new to closed
  • Version set to old-bind10

This issue is related to bind10 code that is no longer part of Kea.

If you are interested in BIND10/Bundy framework or its DNS components,
please check http://bundy-dns.de.

Closing ticket.

Note: See TracTickets for help on using tickets.