Opened 7 years ago

Closed 7 years ago

#2114 closed defect (fixed)

configuration problem; lists nested in named sets

Reported by: jelte Owned by: jelte
Priority: medium Milestone: Sprint-20120717
Component: Unclassified Version:
Keywords: Cc:
CVSS Scoring: Parent Tickets:
Sensitive: no Defect Severity: N/A
Sub-Project: DNS Feature Depending on Ticket:
Estimated Difficulty: 1 Add Hours to Ticket: 0
Total Hours: 0.28 Internal?: no

Description

Vorner found while he was working on the datasources work, that bindctl can't handle named sets consisting of lists of items.

The problem is that when looking for default values, config_data code does check in named sets, but does not take possible lists into account here. The root problem is a lack of recursion in its basic design, but an explicit check for lists should fix this.

In fact, I already have a quick fix patch ready; creating a ticket for it to also add a test, and because it is essentially separate from the other work.

Subtickets

Change History (6)

comment:1 Changed 7 years ago by jelte

  • Owner set to jelte
  • Status changed from new to assigned

comment:2 Changed 7 years ago by jelte

  • Milestone set to Sprint-20120717
  • Owner changed from jelte to UnAssigned
  • Status changed from assigned to reviewing

added unit test and applied fix, ready for review.

fyi, diffs also contain a few whitespace fixes I ran into while I was in those files anyway

comment:3 Changed 7 years ago by vorner

  • Owner changed from UnAssigned to vorner

comment:4 Changed 7 years ago by vorner

  • Owner changed from vorner to jelte

Hello

I think it can be merged. But the code there is getting really messy, step by step :-(.

comment:5 Changed 7 years ago by vorner

  • Total Hours changed from 0 to 0.28

comment:6 Changed 7 years ago by jelte

  • Resolution set to fixed
  • Status changed from reviewing to closed

yes :/

Thanks, merged, closing ticket.

Note: See TracTickets for help on using tickets.