Opened 8 years ago

Closed 6 years ago

#2078 closed task (wontfix)

lettuce test for bind10 -u

Reported by: jreed Owned by:
Priority: medium Milestone: Remaining BIND10 tickets
Component: ~Boss of BIND (obsolete) Version: bind10-old
Keywords: Cc:
CVSS Scoring: Parent Tickets:
Sensitive: no Defect Severity: N/A
Sub-Project: Core Feature Depending on Ticket:
Estimated Difficulty: 5 Add Hours to Ticket: 0
Total Hours: 0 Internal?: no

Description

See ticket #2067 for background.

Add a feature test for bind10 -u.

There is now a unittest that also tests the gid too.

Subtickets

Change History (6)

comment:1 follow-up: Changed 8 years ago by jelte

may the test simply see whether it tries (and fails)?

I'd be hesitant to require root privileges for these tests...

comment:2 in reply to: ↑ 1 Changed 8 years ago by jinmei

Replying to jelte:

may the test simply see whether it tries (and fails)?

I guess the intent was actually to see it works, considering the
background regression for this ticket...

I'd be hesitant to require root privileges for these tests...

Me, too. This seems to be beyond the scope of system tests. On the
other hand, it would be nice if we can have some (semi?) automatic
test framework that tests the entire system in an environment closer
to actual deployments (using installed versions, with chuser, using
privilege port etc). If I hadn't tried to install and run the
"release candidate" on my server, it would have been very likely that
we included the #2067 regression in the release. I normally do this
check at least a few days before the release date for every release,
but it's not very reliable to only depend on such individual practice.

Such a test should probably be disabled by default, and would require
some special setup manually (becoming root, creating 'bind' user,
etc), and maybe manually invoked by hand a few days before the release
(or maybe run from root's cron periodically). (And it may not be
under the "lettuce" directory).

comment:3 Changed 8 years ago by shane

  • Estimated Difficulty changed from 0 to 5

comment:4 Changed 8 years ago by shane

  • Milestone New Tasks deleted

comment:5 Changed 6 years ago by tomek

  • Milestone set to Remaining BIND10 tickets

comment:6 Changed 6 years ago by tomek

  • Resolution set to wontfix
  • Status changed from new to closed
  • Version set to old-bind10

This issue is related to bind10 code that is no longer part of Kea.

If you are interested in BIND10/Bundy framework or its DNS components,
please check http://bundy-dns.de.

Closing ticket.

Note: See TracTickets for help on using tickets.