Opened 7 years ago

Closed 7 years ago

#2067 closed defect (fixed)

cfgmgr cannot open log lock file if started with -u

Reported by: jinmei Owned by: UnAssigned
Priority: very high Milestone: Sprint-20120703
Component: logging Version:
Keywords: Cc:
CVSS Scoring: Parent Tickets:
Sensitive: no Defect Severity: N/A
Sub-Project: Core Feature Depending on Ticket:
Estimated Difficulty: 3 Add Hours to Ticket: 0
Total Hours: 1 Internal?: no

Description

Starting the latest master version of BIND 10 with '-u bind' failed:

2012-06-19 09:37:17.687 INFO  [b10-boss.boss] BIND10_STARTING_PROCESS starting process b10-cfgmgr
Traceback (most recent call last):
  File "/home/jinmei/opt/libexec/bind10-devel/b10-cfgmgr", line 137, in <module>
    sys.exit(main())
  File "/home/jinmei/opt/libexec/bind10-devel/b10-cfgmgr", line 121, in main
    cm.read_config()
  File "/home/jinmei/opt/lib/python3.1/site-packages/isc/config/cfgmgr.py", line 314, in read_config
    self.\
  File "/home/jinmei/opt/lib/python3.1/site-packages/isc/config/cfgmgr.py", line 84, in read_from_file
    logger.info(CFGMGR_CONFIG_FILE, config.db_filename)
RuntimeError: Unable to use interprocess sync lockfile: /home/jinmei/opt/var/bind10-devel/logger_lockfile

This is because the group ID of cfgmgr (and originally bind10 for that
matter) hasn't been changed while the lock file was opened when bind
10 was a root.

I believe this is critical and should be fixed before the release. So
I'm pushing it to the current sprint.

Subtickets

Change History (5)

comment:1 Changed 7 years ago by jinmei

  • Owner set to jinmei
  • Status changed from new to accepted

comment:2 Changed 7 years ago by jinmei

trac2067 is ready for review.

It doesn't include a direct test that -u option really change the gid
(that's the same for the uid, too, though), but I confirmed it worked
on my personal system that previously had the trouble.

It's a visible regression, but I don't think we need a changelog entry
for this as it was only not introduced in the middle of two releases.

comment:3 Changed 7 years ago by jinmei

  • Owner changed from jinmei to UnAssigned
  • Status changed from accepted to reviewing

comment:4 Changed 7 years ago by jinmei

reviewed on jabber, merge done, closing.

I'm giving an estimation point of 3 to this ticket.

comment:5 Changed 7 years ago by jinmei

  • Estimated Difficulty changed from 0 to 3
  • Resolution set to fixed
  • Status changed from reviewing to closed
  • Total Hours changed from 0 to 1
Note: See TracTickets for help on using tickets.