Opened 8 years ago

Closed 7 years ago

#1932 closed defect (duplicate)

zone error caused other zones not to load

Reported by: jreed Owned by:
Priority: high Milestone:
Component: b10-auth Version:
Keywords: Cc:
CVSS Scoring: Parent Tickets:
Sensitive: no Defect Severity: High
Sub-Project: DNS Feature Depending on Ticket:
Estimated Difficulty: 7 Add Hours to Ticket: 0
Total Hours: 0 Internal?: no

Description

(Seen from testing on new as112 server.)

It was configured with multiple "memory" zones under Auth/datasources[0]/zones ...
the final entry zones[19] had a mistake in the master file.

I enabled logging and saw 8 times when I set the name to same file name and did a commit:

2012-05-01 22:36:15.132 ERROR [b10-auth.auth] AUTH_CONFIG_UPDATE_FAIL update of configuration failed: Server configuration failed: Parse failure for a valid RR at line 12

The logging should say what file or zone configuration had failure. On many zones (like 19) it may be difficult to notice. (By the way, named-checkzone didn't notice. The problem was accidental addition of $TTL entry at that line 12.)
I will open a different ticket for this: #1931

I should not get a response of REFUSED for the other configured zones. Once the one zone was fixed (and reload) all the other zones started working too.

The bug is that all zones should be loaded and served and only the erroring zones should be refused.

Subtickets

Change History (4)

comment:1 Changed 8 years ago by shane

  • Milestone changed from New Tasks to Next-Sprint-Proposed
  • Priority changed from medium to high

comment:2 Changed 8 years ago by vorner

I'm not sure if we should fix this or this is the correct behaviour. After all, this was a non-working configuration, so it was rejected whole. Or should a configuration with a wrong zone be accepted?

comment:3 Changed 8 years ago by jinmei

I think if don't have a particular reason for not doing so, we should
be compatible with BIND 9. And, in my understanding, BIND 9 accepts
all valid zones even if some others have critical errors and are not
loaded.

But in any case, I suggest we defer it until we work on the generic
zone loader.

comment:4 Changed 7 years ago by jinmei

  • Resolution set to duplicate
  • Status changed from new to closed

This is a duplicate of #2421. Closing this one (and I think the estimation
of this ticket is now stale anyway, after heavily revising the in-memory internals).

Note: See TracTickets for help on using tickets.