Opened 8 years ago

Closed 5 years ago

#1905 closed defect (wontfix)

error compiling BIND 10 on Solaris 10 x86pc

Reported by: cas Owned by: UnAssigned
Priority: medium Milestone: Remaining BIND10 tickets
Component: build system Version: bind10-old
Keywords: Cc:
CVSS Scoring: Parent Tickets:
Sensitive: no Defect Severity: N/A
Sub-Project: Core Feature Depending on Ticket:
Estimated Difficulty: 6 Add Hours to Ticket: 0
Total Hours: 0 Internal?: no

Description

High level error:

configure:15298: error: Can't compile against Python.h

error in config.log:
/opt/csw/lib/gcc/i386-pc-solaris2.10/4.6.3/include-fixed/sys/feature_tests.h:341:2: error: #error "Compiler or options invalid for pre-UN
IX 03 X/Open applications and pre-2001 POSIX applications"

Subtickets

Attachments (2)

config.log (41.1 KB) - added by cas 8 years ago.
feature_tests.h (13.9 KB) - added by cas 8 years ago.
Solaris 10 i86pc feature_tests.h

Download all attachments as: .zip

Change History (22)

Changed 8 years ago by cas

comment:1 Changed 8 years ago by cas

BIND 10 source used was 20120329

comment:2 follow-up: Changed 8 years ago by jreed

Can you provide the related lines near line 341 in /opt/csw/lib/gcc/i386-pc-solaris2.10/4.6.3/include-fixed/sys/feature_tests.h
?

Thanks

We do not have a Solaris on x86 test system; we will try to get one added to our build farm. We do have Solaris on Sparc.

Changed 8 years ago by cas

Solaris 10 i86pc feature_tests.h

comment:3 in reply to: ↑ 2 Changed 8 years ago by cas

Replying to jreed:

Can you provide the related lines near line 341 in /opt/csw/lib/gcc/i386-pc-solaris2.10/4.6.3/include-fixed/sys/feature_tests.h
?

Hi Jeremy,

I've uploaded the header file to the attachments to this ticket.

-- Carsten

comment:4 Changed 8 years ago by jelte

  • Milestone changed from New Tasks to Sprint-20120515

comment:5 Changed 8 years ago by jinmei

I'm afraid we can't solve this issue without having a system on which
we can reproduce the error. I've examined the header file but it
didn't seem to help much without the actual system.

Can we perhaps get an access to the Solaris box in question?

comment:6 Changed 8 years ago by muks

comment:7 Changed 8 years ago by muks

I installed Solaris 10 in a VM and tested the configure failure. Doing one of two things fixes this error:

  1. Removing or commenting the following lines from pyconfig.h:
    #define _POSIX_C_SOURCE ...
    #define _XOPEN_SOURCE ...
    /* The following is already commented out in my case */
    /* #undef _XOPEN_SOURCE_EXTENDED */
    
  1. Defining -D_XPG6 in CFLAGS.

comment:8 follow-up: Changed 8 years ago by shane

  • Milestone Sprint-20120703 deleted
  • Status changed from new to assigned

Carsten, can you have a try of one of the two fixes that Mukund suggested?

comment:9 in reply to: ↑ 8 ; follow-up: Changed 8 years ago by cas

Replying to shane:

Carsten, can you have a try of one of the two fixes that Mukund suggested?

Will do by tomorrow (Thursday 21st)

comment:10 in reply to: ↑ 9 ; follow-up: Changed 8 years ago by cas

Replying to cas:

Replying to shane:

Carsten, can you have a try of one of the two fixes that Mukund suggested?

Will do by tomorrow (Thursday 21st)

I tested the two workaround listed above, but with no success. I'm getting still the same errors in the configure run.

I'm in Amsterdam next week, I could give my VirtualBox? image to Shane and Shane can make it available to the dev team for testing, if that would help.

-- Carsten

comment:11 in reply to: ↑ 10 Changed 8 years ago by shane

Replying to cas:

Replying to cas:

Replying to shane:

Carsten, can you have a try of one of the two fixes that Mukund suggested?

Will do by tomorrow (Thursday 21st)

I tested the two workaround listed above, but with no success. I'm getting still the same errors in the configure run.

Bummer. :(

I'm in Amsterdam next week, I could give my VirtualBox? image to Shane and Shane can make it available to the dev team for testing, if that would help.

Okay, sounds like it might help. I'll be around all week, so can come and grab this at any time.

comment:12 Changed 7 years ago by cas

problem still exists in 1.0.0-RC, error message below

checking for a Python interpreter with version >= 3.1... python3.1
checking for python3.1... /opt/csw/bin//python3.1
checking for python3.1 version... 3.1
checking for python3.1 platform... sunos5
checking for python3.1 script directory... ${prefix}/lib/python3.1/site-packages
checking for python3.1 extension module directory... ${exec_prefix}/lib/python3.1/site-packages
sed: command garbled: s/\([ \t]*-L\)[ ]*\([^ \t]*[ \t]*\)/\1\2/pg
checking Python.h usability... yes
checking Python.h presence... no
configure: WARNING: Python.h: accepted by the compiler, rejected by the preprocessor!
configure: WARNING: Python.h: proceeding with the compiler's result
checking for Python.h... yes
checking for main in -lpython3.1... yes
checking for setproctitle module... missing
configure: WARNING: Missing setproctitle python module.
Use --disable-setproctitle-check to skip this check.
In this case we will continue, but naming of python processes will not work.
checking whether we need -Wno-unused-parameter for python... configure: error: Can't compile against Python.h.  If you're using MacOS X and have installed Python with Homebrew, see http://bind10.isc.org/wiki/SystemNotesMacOSX

comment:13 Changed 7 years ago by shane

There's a note about this on the SystemNotesSolaris10 page. It didn't seem to work with the -D_XPG6 flag.

Can you confirm that setting that flag works?

$ CFLAGS="-D_XPG6" ./configure [plus tons of flags pointing to installed software...]
Last edited 7 years ago by shane (previous) (diff)

comment:14 Changed 7 years ago by cas

Hi,

I've re-installed my Solaris x86 dev box from scratch, and now I can work around the Python.h issues by removing the 2 defines as documented in the SystemNotesSolaris10.

comment:15 Changed 7 years ago by cas

Now the bind 10 compile fails with an issues that probably is caused by the loader (ld), but there is no information what is going wrong:

  Now you can type "make" to build BIND 10

bash-4.2# make
make  all-recursive
make[1]: Entering directory `/usr/share/src/bind10/bind10-1.0.0'
Making all in compatcheck
make[2]: Entering directory `/usr/share/src/bind10/bind10-1.0.0/compatcheck'
make[2]: Nothing to be done for `all'.
make[2]: Leaving directory `/usr/share/src/bind10/bind10-1.0.0/compatcheck'
Making all in doc
make[2]: Entering directory `/usr/share/src/bind10/bind10-1.0.0/doc'
Making all in guide
make[3]: Entering directory `/usr/share/src/bind10/bind10-1.0.0/doc/guide'
make[3]: Nothing to be done for `all'.
make[3]: Leaving directory `/usr/share/src/bind10/bind10-1.0.0/doc/guide'
make[3]: Entering directory `/usr/share/src/bind10/bind10-1.0.0/doc'
make[3]: Nothing to be done for `all-am'.
make[3]: Leaving directory `/usr/share/src/bind10/bind10-1.0.0/doc'
make[2]: Leaving directory `/usr/share/src/bind10/bind10-1.0.0/doc'
Making all in .
make[2]: Entering directory `/usr/share/src/bind10/bind10-1.0.0'
make[2]: Leaving directory `/usr/share/src/bind10/bind10-1.0.0'
Making all in src
make[2]: Entering directory `/usr/share/src/bind10/bind10-1.0.0/src'
Making all in lib
make[3]: Entering directory `/usr/share/src/bind10/bind10-1.0.0/src/lib'
Making all in exceptions
make[4]: Entering directory `/usr/share/src/bind10/bind10-1.0.0/src/lib/exceptions'
Making all in .
make[5]: Entering directory `/usr/share/src/bind10/bind10-1.0.0/src/lib/exceptions'
  CXX    exceptions.lo
  CXXLD  libb10-exceptions.la
make[5]: *** [libb10-exceptions.la] Error 1
make[5]: Leaving directory `/usr/share/src/bind10/bind10-1.0.0/src/lib/exceptions'
make[4]: *** [all-recursive] Error 1
make[4]: Leaving directory `/usr/share/src/bind10/bind10-1.0.0/src/lib/exceptions'
make[3]: *** [all-recursive] Error 1
make[3]: Leaving directory `/usr/share/src/bind10/bind10-1.0.0/src/lib'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/usr/share/src/bind10/bind10-1.0.0/src'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/usr/share/src/bind10/bind10-1.0.0'
make: *** [all] Error 2

comment:16 Changed 7 years ago by cas

error with "--disable-silent-rules":

make[5]: Entering directory `/usr/share/src/bind10/bind10-1.0.0/src/lib/exceptions'                                                                         
/bin/bash ../../../libtool  --tag=CXX   --mode=link g++ -Wall -Wextra -Wwrite-strings -Woverloaded-virtual -Wno-sign-compare -Wno-missing-braces -Werror -fP
IC -g -O2  -Wl,-R/usr/local/lib          -z now -o libb10-exceptions.la -rpath /usr/local/lib exceptions.lo  -lrt -lsocket -lnsl                            
libtool: link: rm -fr  .libs/libb10-exceptions.so .libs/libb10-exceptions.so.0 .libs/libb10-exceptions.so.0.0.0                                             
libtool: link: g++ -shared -nostdlib  /usr/lib/crti.o /usr/lib/values-Xa.o /opt/csw/lib/gcc/i386-pc-solaris2.10/4.6.3/crtbegin.o  .libs/exceptions.o   -Wl,-
R -Wl,/opt/csw/lib -Wl,-R -Wl,/opt/csw/lib -lrt -lsocket -lnsl -L/opt/csw/lib/gcc/i386-pc-solaris2.10/4.6.3 -L/opt/csw/lib/gcc/i386-pc-solaris2.10/4.6.3/../
../.. /opt/csw/lib/libstdc++.so -lm -lc -lgcc_s /opt/csw/lib/gcc/i386-pc-solaris2.10/4.6.3/crtend.o /usr/lib/crtn.o  -Wl,-R/usr/local/lib   -Wl,-h -Wl,libb1
0-exceptions.so.0 -o .libs/libb10-exceptions.so.0.0.0                                                                                                       
libtool: link: (cd ".libs" && rm -f "libb10-exceptions.so.0" && ln -s "libb10-exceptions.so.0.0.0" "libb10-exceptions.so.0")
libtool: link: (cd ".libs" && rm -f "libb10-exceptions.so" && ln -s "libb10-exceptions.so.0.0.0" "libb10-exceptions.so")
libtool: link: false cru .libs/libb10-exceptions.a  exceptions.o
make[5]: *** [libb10-exceptions.la] Error 1

comment:17 Changed 7 years ago by cas

using GNU ld instead of Solaris ld produced a message for the error:

/bin/bash ../../../libtool  --tag=CXX   --mode=link g++ -Wall -Wextra -Wwrite-strings -Woverloaded-virtual -Wno-sign-compare -Wno-missing-braces -Werror -fP
IC -g -O2  -Wl,-R/usr/local/lib          -z now -o libb10-exceptions.la -rpath /usr/local/lib exceptions.lo  -lrt -lsocket -lnsl                            
libtool: link: rm -fr  .libs/libb10-exceptions.so .libs/libb10-exceptions.so.0 .libs/libb10-exceptions.so.0.0.0                                             
libtool: link: g++ -shared -nostdlib /usr/lib/crti.o /usr/lib/values-Xa.o /opt/csw/lib/gcc/i386-pc-solaris2.10/4.6.3/crtbegin.o  .libs/exceptions.o   -Wl,-r
path -Wl,/opt/csw/lib -Wl,-rpath -Wl,/opt/csw/lib -lrt -lsocket -lnsl -L/opt/csw/lib/gcc/i386-pc-solaris2.10/4.6.3 -L/opt/csw/lib/gcc/i386-pc-solaris2.10/4.
6.3/../../.. /opt/csw/lib/libstdc++.so -lm -lc -lgcc_s /opt/csw/lib/gcc/i386-pc-solaris2.10/4.6.3/crtend.o /usr/lib/crtn.o  -Wl,-R/usr/local/lib   -Wl,-sona
me -Wl,libb10-exceptions.so.0 -o .libs/libb10-exceptions.so.0.0.0                                                                                           
ld: warning: option -o appears more than once, first setting taken
ld: fatal: file /opt/csw/lib: unknown file type
ld: fatal: File processing errors. No output written to .libs/libb10-exceptions.so.0.0.0

comment:18 Changed 7 years ago by cas

I found that despite the setting "export LD=/opt/csw/bin/gld", "g++" was still calling the Solaris linker in "/usr/ccs/bin".

As a quick-n-dirty fix I've tried:

mv /usr/ccs/bin//ld /usr/ccs/bin//ld.org
ln -s /opt/csw/bin/gld /opt/csw/bin/ld

which solved the issue, but is more than a dirty hack.

botan and log4cplus were just compiling fine, just BIND 10 had issues with the setup.

comment:19 Changed 6 years ago by tomek

  • Milestone set to Remaining BIND10 tickets

comment:20 Changed 5 years ago by tomek

  • Resolution set to wontfix
  • Status changed from assigned to closed
  • Version set to bind10-old
Note: See TracTickets for help on using tickets.