Opened 8 years ago

Closed 8 years ago

#1900 closed defect (fixed)

BIND10_STARTED_CC not logged consistently on macmini

Reported by: jreed Owned by: muks
Priority: medium Milestone: Sprint-20120515
Component: ~Boss of BIND (obsolete) Version:
Keywords: Cc:
CVSS Scoring: Parent Tickets:
Sensitive: no Defect Severity: N/A
Sub-Project: Core Feature Depending on Ticket:
Estimated Difficulty: 0 Add Hours to Ticket: 0
Total Hours: 0 Internal?: no

Description

I started bind10 around ten times in a row and BIND10_STARTED_CC was never logged.
I did get related logging (it is working):

2012-04-19 09:57:52.813 INFO  [b10-boss.boss] BIND10_STARTING_CC starting configuration/command session
2012-04-19 09:57:52.834 INFO  [b10-boss.boss] BIND10_READING_BOSS_CONFIGURATION reading boss configuration

This was on macmini system. I didn't see any log corruption but may be related.

Subtickets

Change History (4)

comment:1 Changed 8 years ago by jreed

Not sure if is useful information, but if I moved the logger.debug a couple lines up, so before the isc.config.ModuleCCSession step, then it does work to log it. (But after that it does not log.)

It is also missing the BIND10_STARTED_PROCESS_PID logging.

comment:2 Changed 8 years ago by muks

  • Milestone changed from New Tasks to Sprint-20120501
  • Owner set to UnAssigned
  • Status changed from new to reviewing

This is cause logger was not at DEBUG for the other components. Fixed in the trac1790 branch:

* b0b3abd [1900] Check for CC status before starting inmemory_over_sqlite3.feature

Up for review.

comment:3 Changed 8 years ago by vorner

  • Owner changed from UnAssigned to muks

Comments in the #1790 branch.

comment:4 Changed 8 years ago by muks

  • Resolution set to fixed
  • Status changed from reviewing to closed

Pushed to master as part of ticket #1790:

* c2d70c8 [1900] Check for CC status before starting inmemory_over_sqlite3.feature

Resolving bug as fixed. Thank you for the review.

Note: See TracTickets for help on using tickets.