Opened 8 years ago

Closed 6 years ago

Last modified 6 years ago

#1860 closed task (fixed)

introduce consistently structured exception hierachy in libdns++

Reported by: jinmei Owned by: muks
Priority: medium Milestone: bind10-1.2-release-freeze
Component: libdns++ Version:
Keywords: Cc:
CVSS Scoring: Parent Tickets:
Sensitive: no Defect Severity: N/A
Sub-Project: DNS Feature Depending on Ticket:
Estimated Difficulty: 5 Add Hours to Ticket: 0
Total Hours: 0 Internal?: no

Description

We'll need a module level exception class like isc::dns::Exception, which
is a direct subclass of isc::Exception, and all exception classes
in libdnss++ will be derived from DNSException.

We should also categorize exceptions into some same type of
intermediate classes. It's inconvenient if there's nothing between
a very specific exception type like TooLongName and very generic one
(whether it's isc::Exception or isc::dns::Exception).

This has been long standing issue, but now that we remember it in the
discussion for #1627, I'm raising this for the next sprint. This one
shouldn't be a very big task and would be good for longer term.

Subtickets

Change History (9)

comment:1 Changed 8 years ago by jelte

  • Milestone Next-Sprint-Proposed deleted

comment:2 Changed 6 years ago by muks

  • Milestone set to Sprint-20131015
  • Status changed from new to reviewing

As part of #2518, the name parsing exceptions were first organized.

The rest of this ticket (#1860)'s requirement is also fixed as part of #2518.

comment:3 Changed 6 years ago by pselkirk

  • Milestone changed from bind10-1.2-release-freeze to Sprint-20131015

Should this ticket be marked as duplicate of #2518?

comment:4 follow-up: Changed 6 years ago by muks

  • Milestone changed from Sprint-20131015 to bind10-1.2-release-freeze
  • Owner changed from UnAssigned to pselkirk

This ticket's description is a superset of #2518. Though the work has already been done in trac2518, it is not a duplicate (this ticket is not just about text parsing exceptions). #2518 can't be closed either as it is in review. Both will be closed when #2518 is done.

Can you say either here or in #2518 that you have reviewed it for this ticket's requirements as well?

Sprint-20131015 is complete, so please be careful not to change the milestone back to it.

comment:5 in reply to: ↑ 4 Changed 6 years ago by pselkirk

Replying to muks:

Can you say either here or in #2518 that you have reviewed it for this ticket's requirements as well?

Agreed that #2518 covers the exception hierarchy that is the subject of this ticket, and this can be closed when #2518 is closed.

Sprint-20131015 is complete, so please be careful not to change the milestone back to it.

I think what happened there was that I had this ticket open before the milestone was changed, and didn't refresh the window before updating the ticket.

comment:6 Changed 6 years ago by muks

  • Owner changed from pselkirk to muks

Reassigning to myself. It has to be closed when #2518 is merged.

comment:7 Changed 6 years ago by muks

  • Summary changed from introduce consistently structured exception hierachy in libdns++ to [blocked] introduce consistently structured exception hierachy in libdns++

This ticket is merely waiting for #2518 to be resolved after which it will also be simply closed.

comment:8 Changed 6 years ago by muks

  • Resolution set to fixed
  • Status changed from reviewing to closed

#2518 has been resolved. So resolving this ticket too.

comment:9 Changed 6 years ago by muks

  • Summary changed from [blocked] introduce consistently structured exception hierachy in libdns++ to introduce consistently structured exception hierachy in libdns++
Note: See TracTickets for help on using tickets.