Opened 8 years ago

Closed 5 years ago

#1835 closed task (invalid)

install-sh issue on OpenBSD

Reported by: jreed Owned by: jreed
Priority: medium Milestone: Remaining BIND10 tickets
Component: build system Version:
Keywords: Cc:
CVSS Scoring: Parent Tickets:
Sensitive: no Defect Severity: N/A
Sub-Project: Core Feature Depending on Ticket:
Estimated Difficulty: 3 Add Hours to Ticket: 0
Total Hours: 0 Internal?: no

Description

/bin/sh /bin/sh /home/jreed/src/bind10/install-sh -d 
//home/jreed/opt/bind10/var/bind10-devel

Caused by:

install_sh_DATA = ${SHELL} $(install_sh) -c -m 644
install_sh_PROGRAM = ${SHELL} $(install_sh) -c
install_sh_SCRIPT = ${SHELL} $(install_sh) -c
mkinstalldirs = $(SHELL) $(install_sh) -d
install_sh = ${SHELL} /home/jreed/src/bind10/install-sh
$ /bin/sh /bin/sh
/bin/sh[2]: syntax error: `(' unexpected

The problem is caused by http://www.openbsd.org/cgi-bin/cvsweb/ports/devel/automake/1.11/patches/patch-lib_am_header-vars_am and http://www.openbsd.org/cgi-bin/cvsweb/ports/devel/automake/1.11/patches/patch-automake_in

I reported this to their ports team. I am opening this ticket to track it from our side too.

Subtickets

Change History (8)

comment:1 Changed 8 years ago by jreed

  • Owner changed from UnAssigned to jreed
  • Status changed from new to accepted

comment:2 Changed 8 years ago by jinmei

and what are we expected to do for this ticket?

comment:3 Changed 8 years ago by shane

  • Milestone New Tasks deleted

Do we have a ticket number or something like that from the OpenBSD people?

comment:4 Changed 8 years ago by jreed

I don't have a ticket number or any response yet. I sent them another email as a reminder.

comment:5 Changed 6 years ago by muks

What is the status of this ticket? This is blocking the OpenBSD meta ticket (#1730) from being resolved.

comment:6 Changed 6 years ago by jreed

I will check it this week and if is still broken, I will report upstream again.
But is anyone else using OpenBSD? I am curious if they had the problem.

comment:7 Changed 6 years ago by tomek

  • Milestone set to Remaining BIND10 tickets

comment:8 Changed 5 years ago by tomek

  • Resolution set to invalid
  • Status changed from accepted to closed
Note: See TracTickets for help on using tickets.