Opened 8 years ago

Closed 7 years ago

#1831 closed defect (fixed)

MockXfrinConnection.setblocking is deprecated

Reported by: jreed Owned by: pselkirk
Priority: medium Milestone: Sprint-20130402
Component: xfrin Version:
Keywords: Cc:
CVSS Scoring: Parent Tickets:
Sensitive: no Defect Severity: Low
Sub-Project: DNS Feature Depending on Ticket:
Estimated Difficulty: 1 Add Hours to Ticket: 0
Total Hours: 0 Internal?: no

Description

I didn't research this yet. I saw this when running tests on OpenBSD:

/home/jreed/src/bind10/src/bin/xfrin/xfrin.py:607: DeprecationWarning: MockXfrinConnection.setblocking is deprecated; use MockXfrinConnection.socket.setblocking instead

Subtickets

Change History (12)

comment:1 Changed 8 years ago by shane

  • Defect Severity changed from N/A to Low
  • Milestone New Tasks deleted
  • Sub-Project changed from Core to DNS

comment:2 Changed 7 years ago by shane

  • Milestone set to Next-Sprint-Proposed

comment:3 Changed 7 years ago by shane

  • Milestone changed from Previous-Sprint-Proposed to Next-Sprint-Proposed

comment:4 Changed 7 years ago by shane

  • Milestone changed from Previous-Sprint-Proposed to Next-Sprint-Proposed

comment:5 Changed 7 years ago by shane

  • Milestone changed from Previous-Sprint-Proposed to Next-Sprint-Proposed

comment:6 Changed 7 years ago by shane

  • Milestone changed from Previous-Sprint-Proposed to Next-Sprint-Proposed

comment:7 Changed 7 years ago by shane

I checked, and this is only 2 or 3 places in the code.

comment:8 Changed 7 years ago by jelte

  • Milestone changed from Next-Sprint-Proposed to Sprint-20130402

comment:9 Changed 7 years ago by pselkirk

  • Component changed from Unclassified to xfrin
  • Owner set to UnAssigned
  • Status changed from new to reviewing

Fixed the one instance I could find.

comment:10 Changed 7 years ago by jinmei

Looks okay, please merge.

In the review process, we normally discuss whether the issue is worth
noting in ChangeLog. If the developer thinks so, proposed text
would also be pasted in the ticket comment; if the developer doesn't
think it needs a ChangeLog entry, it would still be better to
explicitly say so. Sometimes it's too obvious that we don't need it
(like fixing a typo in comments), but I'd suggest always following this
usual practice until you are fully familiarized with the process.

And, in this specific case, we probably don't need it, but may not be
very obvious because the noisy warning could be noticed by users.

comment:11 Changed 7 years ago by jinmei

  • Owner changed from UnAssigned to pselkirk

comment:12 Changed 7 years ago by pselkirk

  • Resolution set to fixed
  • Status changed from reviewing to closed

Merged to master branch in commit b59d780f0b9fd66c06eb7d06082e41249b778f94:

* 47b5832 [1831] Fix a deprecation warning in xfrin.py
Note: See TracTickets for help on using tickets.