Opened 8 years ago

Closed 8 years ago

#1818 closed task (fixed)

change default boss config to not run b10-auth

Reported by: jelte Owned by: muks
Priority: medium Milestone: Sprint-20120417
Component: ~Boss of BIND (obsolete) Version:
Keywords: Cc:
CVSS Scoring: Parent Tickets:
Sensitive: no Defect Severity: N/A
Sub-Project: DNS Feature Depending on Ticket:
Estimated Difficulty: 1 Add Hours to Ticket: 0
Total Hours: 2.39 Internal?: no

Description

title speaks for itself.

I don't think this is much work, and I am assigning it 1 point (which i'll steal from the related ticket #1443)

Subtickets

Change History (25)

comment:1 Changed 8 years ago by jelte

  • Estimated Difficulty changed from 0 to 1

comment:2 Changed 8 years ago by muks

  • Owner set to muks
  • Status changed from new to assigned

Picking bug

comment:3 Changed 8 years ago by muks

jelte: Does disabling b10-auth also mean disabling xfrin, xfrout and zonemgr?

comment:4 Changed 8 years ago by muks

jelte replied on Jabber:

muks: jelte: for #1818, does disabling b10-auth also mean disabling xfrin, xfrout and zonemgr?
jelte: i would say yes, but i've been thinking that we really do need an easier way to enable them
jelte: but it doesn't make much sense to run xfrin and xfrout without auth atm, and it really doesn't make sense to run zonemgr without xfrin or xfrout, so yeah

comment:5 Changed 8 years ago by muks

  • Owner changed from muks to UnAssigned
  • Status changed from assigned to reviewing

Up for review.

comment:6 Changed 8 years ago by muks

vorner suggests we should also update the handbook to state that these services don't start by default, and have a section on how to start it.

comment:7 Changed 8 years ago by vorner

  • Owner changed from UnAssigned to vorner

comment:8 follow-up: Changed 8 years ago by vorner

  • Owner changed from vorner to muks

Hello

Hmm, the mentioned documentation in the guide is not in the branch. Is that expected?

Also, while the changes indeed mean it is not started by default, the previous default was used at several places in system and lettuce tests. Would you please run them and fix their configurations to start whatever they need?

Thank you

comment:9 follow-up: Changed 8 years ago by jreed

changelog entry for 407 should have an asterisk for [func]* since a noticable operational change.

comment:10 in reply to: ↑ 9 Changed 8 years ago by muks

Replying to jreed:

changelog entry for 407 should have an asterisk for [func]* since a noticable operational change.

Fixed:

bug #1818: Add * next to [func] as it's a noticable change

comment:11 Changed 8 years ago by jreed

I think the estimated difficulty was wrong :)

comment:12 in reply to: ↑ 8 Changed 8 years ago by muks

Replying to vorner:

Hello

Hmm, the mentioned documentation in the guide is not in the branch. Is that expected?

The guide has been updated now.

Also, while the changes indeed mean it is not started by default, the previous default was used at several places in system and lettuce tests. Would you please run them and fix their configurations to start whatever they need?

make check passed. I'm checking the lettuce tests now.

comment:13 Changed 8 years ago by muks

System tests pass now.

comment:14 Changed 8 years ago by muks

  • Owner changed from muks to UnAssigned

Lettuce tests pass now. Up for review. Assigning to 'UnAssigned?' as it has been a long time.

comment:15 Changed 8 years ago by muks

  • Owner changed from UnAssigned to muks

Taking issue back as there are still some problems with how the lettuce tests are run without checking for service status.

comment:16 Changed 8 years ago by muks

Up for review again. I have addressed the issues to do with components not starting up, or not shutting down before a test is run.

There still seem to be some issues reported on a Mac OS X box:

2012-04-11 06:19:11.401 ERROR [b10-auth.cc] CC_ASYNC_READ_FAILED asynchronous read failed
2012-04-11 06:19:11.402 FATAL [b10-auth.auth] AUTH_SERVER_FAILED server failed: asynchronous read failed
2012-04-11 06:19:11.405 INFO  [b10-boss.boss] BIND10_LOST_SOCKET_CONSUMER consumer 17 of sockets disconnected, considering all its sockets closed
2012-04-11 06:19:11.406 INFO  [b10-boss.boss] BIND10_PROCESS_ENDED process 15511 of b10-auth ended with status 256
2012-04-11 06:19:11.406 ERROR [b10-boss.boss] BIND10_COMPONENT_FAILED component b10-auth (pid 15511) failed: process exited normally with exit status 256
2012-04-11 06:19:11.406 FATAL [b10-boss.boss] BIND10_COMPONENT_UNSATISFIED component b10-auth is required to run and failed
2012-04-11 06:19:11.406 INFO  [b10-boss.boss] BIND10_SHUTDOWN stopping the server
2012-04-11 06:19:11.406 INFO  [b10-boss.boss] BIND10_CONFIGURATOR_STOP bind10 component configurator is shutting down
2012-04-11 06:19:11.407 INFO  [b10-boss.boss] BIND10_COMPONENT_STOP component Socket creator is being stopped
2012-04-11 06:19:11.407 INFO  [b10-boss.boss] BIND10_SOCKCREATOR_TERMINATE terminating socket creator
2012-04-11 06:19:11.407 INFO  [b10-boss.boss] BIND10_COMPONENT_STOP component msgq is being stopped
2012-04-11 06:19:11.407 INFO  [b10-boss.boss] BIND10_COMPONENT_STOP component b10-cmdctl is being stopped
2012-04-11 06:19:11.407 INFO  [b10-boss.boss] BIND10_STOP_PROCESS asking b10-cmdctl to shut down
2012-04-11 06:19:11.407 INFO  [b10-boss.boss] BIND10_COMPONENT_STOP component cfgmgr is being stopped
2012-04-11 06:19:11.407 INFO  [b10-boss.boss] BIND10_STOP_PROCESS asking cfgmgr to shut down
2012-04-11 06:19:12.408 INFO  [b10-boss.boss] BIND10_PROCESS_ENDED process 15510 of b10-cmdctl ended with status 0
2012-04-11 06:19:12.408 INFO  [b10-boss.boss] BIND10_PROCESS_ENDED process 15509 of cfgmgr ended with status 0
2012-04-11 06:19:12.408 INFO  [b10-boss.boss] BIND10_PROCESS_ENDED process 15492 of Socket creator ended with status 0
2012-04-11 06:19:12.408 INFO  [b10-boss.boss] BIND10_SEND_SIGTERM sending SIGTERM to msgq (PID 15494)

But I don't think this has anything to do with the changes made in this branch. The testsuite passes on Linux. Jeremy is going to check it on a different OS.

comment:17 Changed 8 years ago by muks

  • Owner changed from muks to UnAssigned

Jeremy says tests pass on NetBSD too. So someone can review this now.

comment:18 Changed 8 years ago by muks

Because of the number of commits on this branch, it might be worth flattening all the patches into a single one and reviewing changes to each file instead (and looking at git blame output to follow why it was introduced).

comment:19 Changed 8 years ago by vorner

  • Owner changed from UnAssigned to vorner

It is a habit to assign it back to the previous reviewer (so we don't waste time by everybody trying to read all the code). So I'm taking it back ;-)

comment:20 follow-up: Changed 8 years ago by vorner

  • Owner changed from vorner to muks

Hello

First, I'd like to ask which all tickets and issues were fixed on the branch. At least from the point of interest, but I might also have a better look at the code and see if the changes do what they should.

Also, I have few questions:

  • Why are the logging messages about being started changed to INFO? I believe we discussed the startup is too verbose by default and we switched them to DEBUG for that reason (and we may want to switch more). Would it be possible to switch them back to DEBUG and enable debug logging in the lettuce tests to match it against that?
  • Why do you set the components that are being stopped to dispensable? Not that it would matter much, as they should not fail, but the kind only defines what happens when the component fails, not when it stops (stopping it is always considered OK).
  • I believe there's a missing space here, just after {, it looks inconsistent with the rest:
    	"b10-auth": {"kind": "dispensable", "special": "auth" },
    
    This is in all these files:
    • tests/lettuce/configurations/bindctl_commands.config.orig
    • tests/lettuce/configurations/example.org.config.orig
    • tests/lettuce/configurations/example.org.inmem.config
    • tests/lettuce/configurations/example2.org.config
    • tests/lettuce/configurations/ixfr-out/testset1-config.db
    • tests/lettuce/configurations/no_db_file.config
    • tests/lettuce/configurations/xfrin/retransfer_master.conf
    • tests/lettuce/configurations/xfrin/retransfer_slave.conf
    • tests/system/glue/nsx1/b10-config.db.in
    • tests/system/ixfr/b10-config.db.in

Also, could you try merging master into the branch to see if there are any significant conflicts? The branch seems to be rather old.

comment:21 Changed 8 years ago by vorner

And, I forgot to mention, I removed few spaces at the ends of lines, so you might want to pull first O:-).

comment:22 in reply to: ↑ 20 ; follow-up: Changed 8 years ago by muks

Hi vorner

Thanks for the review again :) Comments are below:

Replying to vorner:

Hello

First, I'd like to ask which all tickets and issues were fixed on the branch. At least from the point of interest, but I might also have a better look at the code and see if the changes do what they should.

#1818, #1863 and #1853 are fixed by the patches in the trac1818 branch. They are all necessary to pass lettuce tests.

Also, I have few questions:

  • Why are the logging messages about being started changed to INFO? I believe we discussed the startup is too verbose by default and we switched them to DEBUG for that reason (and we may want to switch more). Would it be possible to switch them back to DEBUG and enable debug logging in the lettuce tests to match it against that?

This is now fixed.

  • Why do you set the components that are being stopped to dispensable? Not that it would matter much, as they should not fail, but the kind only defines what happens when the component fails, not when it stops (stopping it is always considered OK).

This was done to test with the other option, as we noticed that bind10 was shutting down in jreed's build slave. But later it was found to be due to a different reason. As you note, it doesn't matter both ways for our tests.

  • I believe there's a missing space here, just after {, it looks inconsistent with the rest:
    	"b10-auth": {"kind": "dispensable", "special": "auth" },
    
    This is in all these files:
    • tests/lettuce/configurations/bindctl_commands.config.orig
    • tests/lettuce/configurations/example.org.config.orig
    • tests/lettuce/configurations/example.org.inmem.config
    • tests/lettuce/configurations/example2.org.config
    • tests/lettuce/configurations/ixfr-out/testset1-config.db
    • tests/lettuce/configurations/no_db_file.config
    • tests/lettuce/configurations/xfrin/retransfer_master.conf
    • tests/lettuce/configurations/xfrin/retransfer_slave.conf
    • tests/system/glue/nsx1/b10-config.db.in
    • tests/system/ixfr/b10-config.db.in

This is now fixed.

Also, could you try merging master into the branch to see if there are any significant conflicts? The branch seems to be rather old.

I will have to do this anyway when pushing to master, and will do it once properly then. Chances of conflicts are unlikely as the majority of the changes are inside tests/. I'll be running system and lettuce tests to verify after merging (before pushing into master).

I can confirm that the test suite passes on Linux and NetBSD (tested by jreed). On Mac OS X (tested by jreed) it fails sometimes due to issues tracked in other bugs (#1629 for one).

This bug has taken way more time than we thought for it. It would be nice to get it merged and closed here if it satisfies this bug's description. Any issues due to unrelated problems can be tracked in other bugs.

comment:23 Changed 8 years ago by muks

  • Owner changed from muks to vorner

comment:24 in reply to: ↑ 22 Changed 8 years ago by vorner

  • Owner changed from vorner to muks
  • Total Hours changed from 0 to 2.39

Hello

Replying to muks:

#1818, #1863 and #1853 are fixed by the patches in the trac1818 branch. They are all necessary to pass lettuce tests.

Hmm, they are being reviewed separately? Well, why not…

Also, could you try merging master into the branch to see if there are any significant conflicts? The branch seems to be rather old.

I will have to do this anyway when pushing to master, and will do it once properly then. Chances of conflicts are unlikely as the majority of the changes are inside tests/. I'll be running system and lettuce tests to verify after merging (before pushing into master).

If you expect no problems, then it should be OK.

This bug has taken way more time than we thought for it. It would be nice to get it merged and closed here if it satisfies this bug's description. Any issues due to unrelated problems can be tracked in other bugs.

Of course. And it looks clean now, so please merge.

comment:25 Changed 8 years ago by muks

  • Resolution set to fixed
  • Status changed from reviewing to closed

Pushed to master:

* 4653281 [1818] Add ChangeLog entry
* 0f9b1d4 [1818] Switch back to DEBUG log level for process starting messages
* d3fd5c7 [1818] Add spacing for consistency
* ae46e78 [1818] Removed spaces at the end of line
* 0464833 [1818] Untabify *.feature files
* 2c8983c [1818] Wait twice for AUTH_SERVER_STARTED in lettuce multi instance test
* c89bd8e [1818] Report the error code when CC_ASYNC_READ_FAILED is logged
* 22041b8 [1818] Check that StatsHttpd is not running by default too
* 66a9862 [1863] Make stats-httpd listen on a non-default port for lettuce tests (contd.)
* 2fd8732 [1863] Make stats-httpd listen on a non-default port for lettuce tests
* 5a3ba49 [1818] Set kind of components that are stopped during tests to dispensable
* efc43a6 [1818] Run lettuce tests in lockstep, checking availability of services (contd.)
* d833b85 [1818] Run lettuce tests in lockstep, checking availability of services
* 3e27e15 [1818] Log cc startup as info message
* 412304a [1818] Wait for components to start before testing them
* a2da847 [1818] Log components startup properly
* 8b8dbb6 [1818] Fix argument list in wait_for_stdout_message()
* 837533a [1818] Use different function names for stderr and stdout waiters
* c545fba [1818] Fix rest of the lettuce tests (these were missing the resolver component)
* 2e25759 [1818] Rename database file (already renamed in config file)
* 0a9dad7 [1818] Start more components when running lettuce tests
* ff240f0 [1818] Fix b10-stats-httpd address and re-enable check
* 7544617 [1818] Rearrange checks for components
* c537d66 [1818] Rearrange tests commenting out StatsHttpd (see bug #1852)
* cf96b2a [1853] Fix module_is_running() to check for component exactly
* 92c00e5 [1818] Add method to sleep for some seconds
* 8cdf67b [1818] Fix a config file to start various components
* 69bcd53 [1818] Don't check for auth when starting bind10 in lettuce tests
* a83554c [1818] Prepend to PYTHONPATH, don't replace it
* 9cc9ffd [1818] Add lettuce test for the default configuration of bind10
* c3b46d0 [1818] Fix zones sqlite3 filename
* 034bc4e Start more components when running ixfr tests
* b303b43 Start more components when running glue tests
* b7f8713 [1818] Show log when retrying verification
* 22aa6ee [1818] Don't show dig output for expected failures
* b23c36e [1818] Fix counters as dig is not called during startup verify anymore
* a17f42a [1818] Use bindctl to verify server instead of dig
* 0d2ebae bug #1818: Update system test for components that are not started by default
* 325b813 bug #1818: Update guide to reflect components that are not started by default
* be50e95 bug #1818: Update manpage removing deleted elements from default list
* 31de885 bug #1818: Don't start b10-auth, xfrin, xfrout, zonemgr in default config

Resolving bug as fixed.

Note: See TracTickets for help on using tickets.