Opened 8 years ago

Closed 5 years ago

#1765 closed defect (wontfix)

config go, then config show datasources does no work

Reported by: jreed Owned by:
Priority: medium Milestone: Remaining BIND10 tickets
Component: ~bind-ctl (obsolete) Version: bind10-old
Keywords: Cc:
CVSS Scoring: Parent Tickets:
Sensitive: no Defect Severity: N/A
Sub-Project: Core Feature Depending on Ticket:
Estimated Difficulty: 0 Add Hours to Ticket: 0
Total Hours: 0 Internal?: no

Description

> config go Auth
/Auth> config show 
database_file        listen_on            
datasources          statistics-interval  
/Auth> config show datasources 
/Auth> config show Auth
/Auth> config show /Auth
Error: Auth not found
/Auth> config show data
database_file  datasources    
/Auth> config show_json
{"datasources": [{"zones": [{"origin": "smallzone", "file": "/home/jreed/dnsbenchsuite/tests/smallzone/master.zone.file-canonical"}], "type": "memory"}], "listen_on": [{"port": 5300, "address": "127.0.0.1"}]}
/Auth> config show datasources 
/Auth> config go /
> config show Auth/data
database_file  datasources    
> config show Auth/data
database_file  datasources    
> config show Auth/datasources 
Auth/datasources[0]/type        "memory"        string
Auth/datasources[0]/class       "IN"    string  (default)
Auth/datasources[0]/zones/      list
> 

(notice tab completion in output above)

An additional problem is config show /Auth doesn't work.

Subtickets

Change History (3)

comment:1 Changed 8 years ago by shane

  • Milestone New Tasks deleted

comment:2 Changed 5 years ago by tomek

  • Milestone set to Remaining BIND10 tickets

comment:3 Changed 5 years ago by tomek

  • Resolution set to wontfix
  • Status changed from new to closed
  • Version set to old-bind10

This issue is related to bind10 code that is no longer part of Kea.

If you are interested in BIND10/Bundy framework or its DNS components,
please check http://bundy-dns.de.

Closing ticket.

Note: See TracTickets for help on using tickets.