Opened 8 years ago

Closed 6 years ago

#1730 closed defect (wontfix)

OpenBSD meta ticket

Reported by: jreed Owned by:
Priority: medium Milestone: Remaining BIND10 tickets
Component: Unclassified Version: bind10-old
Keywords: Cc:
CVSS Scoring: Parent Tickets:
Sensitive: no Defect Severity: N/A
Sub-Project: Core Feature Depending on Ticket:
Estimated Difficulty: 0 Add Hours to Ticket: 0
Total Hours: 0 Internal?: no

Description (last modified by jreed)

OpenBSD openbsd5-64 5.0 amd64

But it is not enabled in the build farm yet due to some issues:

system include header ordering needs
#1644

incomplete pc file for botan and wrong filename for botan-config
#1640

perfdhcp.c uses pselect
#1639

SessionTests hang on OpenBSD
#1726

IntervalTimerTest.invalidArgumentToIntervalTimer failure
#1727

python import and versioned modules
#1728

HashTest? tests fail on OpenBSD
#1812

IfaceMgrTest?.sendReceive6 test hangs on OpenBSD
#1824

CC Session timeouts / ConfigManager? not responding (on OpenBSD)
#1829

install-sh issue on OpenBSD
#1835

Subtickets

Change History (9)

comment:1 Changed 8 years ago by jreed

  • Description modified (diff)

comment:2 Changed 8 years ago by shane

  • Milestone New Tasks deleted

comment:3 Changed 8 years ago by jreed

  • Description modified (diff)

comment:4 Changed 8 years ago by muks

  • Description modified (diff)

Add #1812 (HashTest? tests fail on OpenBSD)

comment:5 Changed 8 years ago by muks

  • Description modified (diff)

Add #1824 (IfaceMgrTest?.sendReceive6 test hangs on OpenBSD)

comment:6 Changed 8 years ago by jreed

  • Description modified (diff)

add #1829

comment:7 Changed 8 years ago by jreed

  • Description modified (diff)

I found install-sh issue is caused by OpenBSD's custom patched automake. Opened ticket for us track this: #1835

comment:8 Changed 6 years ago by tomek

  • Milestone set to Remaining BIND10 tickets

comment:9 Changed 6 years ago by tomek

  • Resolution set to wontfix
  • Status changed from new to closed
  • Version set to old-bind10

This issue is related to bind10 code that is no longer part of Kea.

If you are interested in BIND10/Bundy framework or its DNS components,
please check http://bundy-dns.de.

Closing ticket.

Note: See TracTickets for help on using tickets.