Opened 8 years ago

Closed 8 years ago

#1726 closed defect (duplicate)

SessionTests hang on OpenBSD

Reported by: jreed Owned by: muks
Priority: medium Milestone: Sprint-20120320
Component: Unclassified Version:
Keywords: Cc: jinmei
CVSS Scoring: Parent Tickets:
Sensitive: no Defect Severity: N/A
Sub-Project: Core Feature Depending on Ticket:
Estimated Difficulty: 7 Add Hours to Ticket: 0
Total Hours: 0 Internal?: no

Description

These appear to all hang:

Making check in cc
...
[----------] 6 tests from SessionTest
[ RUN      ] SessionTest.timeout_on_connect

and:

[ RUN      ] SessionTest.connect_ok

and:

[ RUN      ] SessionTest.connect_ok_no_timeout

and:

[ RUN      ] SessionTest.connect_ok_connection_reset

and:

[ RUN      ] SessionTest.run_with_handler

and:

[ RUN      ] SessionTest.run_with_handler_timeout

(I manually disabled each.)

I didn't troubleshoot this yet.

Subtickets

Change History (10)

comment:1 Changed 8 years ago by shane

  • Milestone changed from New Tasks to Next-Sprint-Proposed

comment:2 Changed 8 years ago by jelte

  • Estimated Difficulty changed from 0 to 7

comment:3 Changed 8 years ago by jelte

  • Milestone changed from Next-Sprint-Proposed to Sprint-20120320

comment:4 Changed 8 years ago by shane

See also what this does to #1729!

comment:5 Changed 8 years ago by muks

  • Owner set to muks
  • Status changed from new to assigned

Picking

comment:6 Changed 8 years ago by muks

Compiling with -DBOOST_DISABLE_THREADS fixes this issue.

comment:7 follow-up: Changed 8 years ago by muks

  • Cc jinmei added

jinmei: Though strictly not a duplicate, this seems to be the same underlying issue as that of ticket #1727. Shall I close it as a duplicate of that ticket?

comment:8 Changed 8 years ago by muks

Some changes that went into master so far:

* 5c61cd7 [master] Fix kqueue testcase in configure.ac for OpenBSD
* 61992b3 [master] Add more missing includes (doesn't compile on OpenBSD otherwise)
* 579ba09 Add missing more includes (doesn't compile on OpenBSD otherwise)
* 09d97fb [master] Add missing include (doesn't compile on OpenBSD otherwise
* 1303709 [master] Add missing include (doesn't compile on OpenBSD otherwise)

comment:9 in reply to: ↑ 7 ; follow-up: Changed 8 years ago by jinmei

Replying to muks:

jinmei: Though strictly not a duplicate, this seems to be the same underlying issue as that of ticket #1727. Shall I close it as a duplicate of that ticket?

I you were able to reproduce the problem without the CPPFLAG and then
confirmed it solved the problem, I think you can close this ticket as a duplicate.

comment:10 in reply to: ↑ 9 Changed 8 years ago by muks

  • Resolution set to duplicate
  • Status changed from assigned to closed

Replying to jinmei:

I you were able to reproduce the problem without the CPPFLAG and then
confirmed it solved the problem, I think you can close this ticket as a duplicate.

Without the CPPFLAGS, it fails every time (both with select and kqueue). With CPPFLAGS it passes every time.

So that confirms it. I'm resolving this as a duplicate of #1727.

Note: See TracTickets for help on using tickets.