Opened 8 years ago

Closed 7 years ago

#1725 closed defect (fixed)

improve get_sock.udp6_create test for Solaris

Reported by: jreed Owned by: jinmei
Priority: low Milestone: Sprint-20130219
Component: Unclassified Version:
Keywords: Cc:
CVSS Scoring: Parent Tickets:
Sensitive: no Defect Severity: N/A
Sub-Project: Core Feature Depending on Ticket:
Estimated Difficulty: 4 Add Hours to Ticket: 0
Total Hours: 0 Internal?: no

Description

See http://git.bind10.isc.org/~tester/builder/BIND10/20120229085001-Solaris10-sparc-Sunstudio/logs/unittests.out

[ RUN      ] get_sock.udp6_create
sockcreator_tests.cc:127: Failure
Expected: (0) != (options), actual: 0 vs 0
[  FAILED  ] get_sock.udp6_create (0 ms)

On the SunStudio? Sparc build I configured the build to skip the get_sock.udp6_create test now due to that. (Maybe need to do for GCC build there too, but his a build failure earlier.

For more information, see this thread: https://lists.isc.org/pipermail/bind10-dev/2012-February/003119.html

Subtickets

Change History (12)

comment:1 Changed 8 years ago by jreed

Also on gcc, so I will exclude there also.

comment:2 Changed 8 years ago by shane

  • Milestone New Tasks deleted

FYI, Larissa has asked some contacts of ours at Oracle about this. Hopefully we'll hear something soon.

comment:3 Changed 8 years ago by jinmei

  • Milestone set to Next-Sprint-Proposed

comment:4 Changed 8 years ago by jinmei

Hmm, I don't know how we can fix it. Obviously we didn't hear from
the authority "soon", and I suspect we cannot rely on it. My revised
suggestion is to first check it on the new Solaris 11 box, and,
depending on its result, simply "ifdef"-out the buggy Solaris
versions. Ugly workaround, but since it's a test after all, that
would be acceptable.

comment:5 Changed 7 years ago by jelte

  • Milestone set to Next-Sprint-Proposed

I just ran into this on solaris 10 with gcc as well

comment:6 Changed 7 years ago by jelte

  • Milestone changed from Next-Sprint-Proposed to Sprint-20130205
  • Priority changed from high to low

comment:7 Changed 7 years ago by jinmei

  • Owner set to jinmei
  • Status changed from new to accepted

comment:8 Changed 7 years ago by jinmei

trac1725 is ready for review.

First, I confirmed the test passed on Solaris 11 (at least our
buildbot instance of that version). So I simply disabled the
offending test in question for Solaris 10 as I proposed in
http://bind10.isc.org/ticket/1725#comment:4

I ran the branch on both Solaris 10 and 11 and confirmed it worked as
expected. I also confirmed it didn't cause any unexpected disruption
on my laptop (OSX, i.e., non Solaris).

This is only for minor case of unit tests, so I don't think we need
a changelog entry for it.

comment:9 Changed 7 years ago by jinmei

  • Owner changed from jinmei to UnAssigned
  • Status changed from accepted to reviewing

comment:10 follow-up: Changed 7 years ago by jelte

  • Owner changed from UnAssigned to jinmei

check. Makes tests pass on my solaris 10 as well (and no hickups on my debian).

Please go ahead and merge.

comment:11 in reply to: ↑ 10 Changed 7 years ago by jinmei

Replying to jelte:

check. Makes tests pass on my solaris 10 as well (and no hickups on my debian).

Please go ahead and merge.

Thanks, merge done, closing.

comment:12 Changed 7 years ago by jinmei

  • Resolution set to fixed
  • Status changed from reviewing to closed
Note: See TracTickets for help on using tickets.