Opened 8 years ago

Closed 8 years ago

#1715 closed defect (fixed)

bindctl crash on config unset Boss/components/b10-auth-2

Reported by: jreed Owned by: vorner
Priority: medium Milestone: Sprint-20120403
Component: ~bind-ctl (obsolete) Version:
Keywords: Cc:
CVSS Scoring: Parent Tickets:
Sensitive: no Defect Severity: N/A
Sub-Project: Core Feature Depending on Ticket:
Estimated Difficulty: 4 Add Hours to Ticket: 0
Total Hours: 1.92 Internal?: no

Description

> config unset Boss/components/b10-auth-2
Traceback (most recent call last):
  File "/usr/pkg/lib/python3.1/cmd.py", line 213, in onecmd
    func = getattr(self, 'do_' + cmd)
AttributeError: 'BindCmdInterpreter' object has no attribute 'do_config'

During handling of the above exception, another exception occurred:

Traceback (most recent call last):
  File "/home/reed/opt/bind10/bin/bindctl", line 149, in <module>
    result = tool.run()
  File "/home/reed/opt/bind10/lib/python3.1/site-packages/bindctl/bindcmd.py", line 138, in run
    self.cmdloop()
  File "/usr/pkg/lib/python3.1/cmd.py", line 139, in cmdloop
    stop = self.onecmd(line)
  File "/home/reed/opt/bind10/lib/python3.1/site-packages/bindctl/bindcmd.py", line 466, in onecmd
    Cmd.onecmd(self, line)
  File "/usr/pkg/lib/python3.1/cmd.py", line 215, in onecmd
    return self.default(line)
  File "/home/reed/opt/bind10/lib/python3.1/site-packages/bindctl/bindcmd.py", line 432, in default
    self._parse_cmd(line)
  File "/home/reed/opt/bind10/lib/python3.1/site-packages/bindctl/bindcmd.py", line 569, in _parse_cmd
    self._handle_cmd(cmd)
  File "/home/reed/opt/bind10/lib/python3.1/site-packages/bindctl/bindcmd.py", line 410, in _handle_cmd
    self.apply_config_cmd(cmd)
  File "/home/reed/opt/bind10/lib/python3.1/site-packages/bindctl/bindcmd.py", line 695, in apply_config_cmd
    self.config_data.unset(identifier)
AttributeError: 'UIModuleCCSession' object has no attribute 'unset'

Subtickets

Change History (8)

comment:1 Changed 8 years ago by shane

  • Milestone New Tasks deleted

comment:2 Changed 8 years ago by jelte

  • Milestone set to Next-Sprint-Proposed

comment:3 Changed 8 years ago by jelte

  • Estimated Difficulty changed from 0 to 4

comment:4 Changed 8 years ago by jelte

  • Milestone changed from Next-Sprint-Proposed to Sprint-20120403

comment:5 Changed 8 years ago by vorner

  • Owner set to vorner
  • Status changed from new to accepted

comment:6 Changed 8 years ago by vorner

  • Owner changed from vorner to UnAssigned
  • Status changed from accepted to reviewing

Hello

The cause was someone forgot to implement the unset method on one level of several layers of indirections. And, obviously, there was no test trying to use the command.

The changelog could look like:

[bug]		vorner
Fixed crash in bindctl when config unset was called.

comment:7 Changed 8 years ago by jelte

  • Owner changed from UnAssigned to vorner

ok, this looks fine, go ahead and merge

comment:8 Changed 8 years ago by vorner

  • Resolution set to fixed
  • Status changed from reviewing to closed
  • Total Hours changed from 0 to 1.92
Note: See TracTickets for help on using tickets.