Opened 10 years ago

Closed 9 years ago

Last modified 9 years ago

#158 closed enhancement (fixed)

run_bind10.sh does not really work

Reported by: jreed Owned by: jreed
Priority: low Milestone:
Component: ~Boss of BIND (obsolete) Version:
Keywords: Cc:
CVSS Scoring: Parent Tickets:
Sensitive: no Defect Severity: N/A
Sub-Project: Core Feature Depending on Ticket:
Estimated Difficulty: 0.0 Add Hours to Ticket:
Total Hours: Internal?: no

Description

I don't see where in bind10 it knows how to run the run_*.sh components.

So if no "make install" then b10-xfrin and b10-xfrout can't find bind10_dns and bind10_xfr (respectively) for example.

I had worked at making the run_*.sh scripts be able to find libraries in the source tree, so they do work if ran individually.

Subtickets

Attachments (1)

run.diff (1.7 KB) - added by jinmei 10 years ago.

Download all attachments as: .zip

Change History (7)

comment:1 Changed 10 years ago by jreed

My suggestion is to get rid of the run_*.sh scripts.

Changed 10 years ago by jinmei

comment:2 in reply to: ↑ description Changed 10 years ago by jinmei

  • Owner set to jreed
  • Status changed from new to assigned

Replying to jreed:

I don't see where in bind10 it knows how to run the run_*.sh components.

So if no "make install" then b10-xfrin and b10-xfrout can't find bind10_dns and bind10_xfr (respectively) for example.

I had worked at making the run_*.sh scripts be able to find libraries in the source tree, so they do work if ran individually.

We can pass PYTHONPATH from the boss as an environment variable.

One possible problem is that the python scripts running in the "source mode" still refer to the installed paths, which may be confused (e.g. a script may use an installed, old version of library in some case and use a new version only in the source tree in the other case).

I believe all of the problem is solvable by a patch like the one attached.

And, I still believe it's beneficial to allow the programs to run under the source tree. It will reduce the steps of code-build-try-fix by eliminating the need of 'make install'.

If this is convincing, I'll apply the same fix to other scripts.

comment:3 Changed 10 years ago by shane

  • Component changed from Unclassified to Boss of BIND
  • Priority changed from major to minor
  • Type changed from defect to enhancement

What happened with this? It looks like something similar but not exactly the attached patch was done to the code.

comment:4 Changed 10 years ago by jreed

I committed the change for run_bind10.sh.in. That makes it work for me.

I do understand that python scripts will still use the python modules from the install location (if was installed). I didn't commit the change for the xfrin yet for this as I see that the other scripts need to be handled too. I can do this. (Don't sys.path.append the installed python path location if B10_FROM_SOURCE is defined.)

comment:5 Changed 9 years ago by shane

  • Defect Severity set to N/A
  • Internal? unset
  • Resolution set to fixed
  • Status changed from assigned to closed
  • Sub-Project set to DNS

comment:6 Changed 9 years ago by shane

  • Sub-Project changed from DNS to Core
Note: See TracTickets for help on using tickets.