Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#1557 closed defect (fixed)

fixed regression for auth/query_bench

Reported by: jinmei Owned by: jinmei
Priority: medium Milestone: Sprint-20120124
Component: b10-auth Version:
Keywords: Cc:
CVSS Scoring: Parent Tickets:
Sensitive: no Defect Severity: N/A
Sub-Project: DNS Feature Depending on Ticket:
Estimated Difficulty: 0 Add Hours to Ticket: 0
Total Hours: 0.5 Internal?: no

Description

We need to initialize logging, otherwise it would fail with an
exception. For now I propose to just disable logging. In future
we might want to make it configurable so that we can take into account
the overhead of logging too.

I have already written a fix (attaching patch), so putting this ticket
to the review queue and the ticket for a proposed next sprint item.

Subtickets

Attachments (1)

query_bench.diff (1.1 KB) - added by jinmei 8 years ago.

Download all attachments as: .zip

Change History (9)

Changed 8 years ago by jinmei

comment:1 Changed 8 years ago by jinmei

  • Owner set to UnAssigned
  • Status changed from new to reviewing

comment:2 Changed 8 years ago by jinmei

The patch is really small, but as it seems to be going to be shared with some others right
now, I also created a branch: trac1557.

comment:3 Changed 8 years ago by jelte

  • Milestone changed from Next-Sprint-Proposed to Sprint-20120124

comment:4 Changed 8 years ago by jelte

  • Owner changed from UnAssigned to jelte

comment:5 follow-up: Changed 8 years ago by jelte

  • Owner changed from jelte to jinmei

Looks good, please merge

comment:6 in reply to: ↑ 5 Changed 8 years ago by jinmei

Replying to jelte:

Looks good, please merge

Thanks, merged, closing ticket.

(BTW I don't think we need a changelog entry for this as it's mostly
internal only tool).

comment:7 Changed 8 years ago by jinmei

  • Resolution set to fixed
  • Status changed from reviewing to closed

comment:8 Changed 8 years ago by jinmei

  • Total Hours changed from 0 to 0.5
Note: See TracTickets for help on using tickets.