Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#1549 closed defect (duplicate)

in-memory datasource load multiple RRSIGs

Reported by: jreed Owned by:
Priority: medium Milestone:
Component: data source Version:
Keywords: Cc:
CVSS Scoring: Parent Tickets:
Sensitive: no Defect Severity: N/A
Sub-Project: DNS Feature Depending on Ticket:
Estimated Difficulty: 0 Add Hours to Ticket: 0
Total Hours: 0 Internal?: no

Description

in-memory datasource fails to load a signed zone resulting with: "CMDCTL_COMMAND_ERROR error in command set_config to module ConfigManager?: Server configuration failed: Duplicate rrset" error.

This is caused by having RRSIGs for same label not grouped.

The workaround is to put them together in zone file. (Note that named-checkzone -D does not do this.)

Subtickets

Change History (2)

comment:1 Changed 8 years ago by jinmei

  • Resolution set to duplicate
  • Status changed from new to closed

#1614 should solve this. For now I'll close this ticket as duplicate.

comment:2 Changed 8 years ago by shane

  • Milestone New Tasks deleted
Note: See TracTickets for help on using tickets.