Opened 8 years ago

Closed 7 years ago

#1489 closed defect (duplicate)

added Boss component needs kind

Reported by: jreed Owned by:
Priority: medium Milestone:
Component: Unclassified Version:
Keywords: Cc:
CVSS Scoring: Parent Tickets:
Sensitive: no Defect Severity: Medium
Sub-Project: Core Feature Depending on Ticket:
Estimated Difficulty: 3 Add Hours to Ticket: 0
Total Hours: 0 Internal?: no

Description

I did:

> config add Boss/components b10-resolver
> config commit              
Error: 'kind'
Configuration not committed
> config show Boss/components/b10-resolver
Boss/components/b10-resolver/special    null    string
Boss/components/b10-resolver/process    null    string
Boss/components/b10-resolver/kind       "dispensable"   string  (default)
Boss/components/b10-resolver/address    null    string
Boss/components/b10-resolver/params/    list
Boss/components/b10-resolver/priority   null    integer
>

So "kind" is defined as shown above but still fails.

> config set Boss/components/b10-resolver/kind "dispensable"
> config commit

Maybe this is not a bug in boss but is a known issue in the cfgmgr.

Subtickets

Change History (8)

comment:1 Changed 8 years ago by shane

  • Defect Severity changed from N/A to Medium
  • Milestone changed from New Tasks to Next-Sprint-Proposed

comment:2 Changed 8 years ago by vorner

I believe it's a bug of bindctl.

comment:3 Changed 8 years ago by jelte

it sounds like the same problem as the 'Error: class' in another module which got fixed in the previous sprint, which was a bug of not checking for defaults. Such errors could be prevented by not passing raw changed data around, but data that itself includes its specification and hence defaults, but for this ticket it is probably much easier to simply check whether the value exists and pull the default from the spec if it doesn't.

comment:4 Changed 8 years ago by jelte

  • Estimated Difficulty changed from 0 to 3

comment:5 Changed 8 years ago by jinmei

  • Milestone changed from Year 3 Task Backlog to Next-Sprint-Proposed

comment:6 follow-up: Changed 8 years ago by jreed

Maybe duplicated by #1491?

comment:7 in reply to: ↑ 6 Changed 7 years ago by jinmei

Replying to jreed:

Maybe duplicated by #1491?

and #2064. closing this one.

Last edited 7 years ago by jinmei (previous) (diff)

comment:8 Changed 7 years ago by jinmei

  • Resolution set to duplicate
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.