Opened 8 years ago

Closed 7 years ago

#1486 closed defect (fixed)

IOAddress::from_bytes() should be renamed fromBytes()

Reported by: jinmei Owned by: stephen
Priority: medium Milestone: Sprint-DHCP-20121129
Component: dhcp Version:
Keywords: Cc:
CVSS Scoring: Parent Tickets:
Sensitive: no Defect Severity: N/A
Sub-Project: DHCP Feature Depending on Ticket:
Estimated Difficulty: 0 Add Hours to Ticket: 0
Total Hours: 0 Internal?: no


Per the coding guidelines.

Giving the ticket to DHCP, as it seemed to be added for the DHCP work.


Change History (7)

comment:1 Changed 8 years ago by shane

  • Milestone changed from New Tasks to DHCP 2011

comment:2 Changed 7 years ago by stephen

  • Milestone changed from DHCP 2012 to Sprint-DHCP-20121129

comment:3 Changed 7 years ago by stephen

  • Owner set to stephen
  • Status changed from new to assigned

comment:4 follow-up: Changed 7 years ago by stephen

  • Owner changed from stephen to UnAssigned
  • Status changed from assigned to reviewing

comment:5 in reply to: ↑ 4 Changed 7 years ago by jinmei

Replying to stephen:

I just happened to see the diff in email. This should be so trivial
so assuming you confirm it compiles (I didn't check it), I think it's okay for merge.

One possible point of discussion is whether we want to have a changelog entry.
Probably not as it's mostly an internal API, but I'd leave it to you anyway.

comment:6 Changed 7 years ago by jinmei

  • Owner changed from UnAssigned to stephen

comment:7 Changed 7 years ago by stephen

  • Resolution set to fixed
  • Status changed from reviewing to closed

Merged in commit 2f15c7833baf7c67d20df974093db92acb0ae09c

Decided against a ChangeLog entry as it is just a change to an internal API.

Note: See TracTickets for help on using tickets.