Opened 8 years ago

Closed 8 years ago

#1426 closed defect (duplicate)

Must set default class in zonemgr configuration

Reported by: shane Owned by:
Priority: medium Milestone:
Component: Unclassified Version:
Keywords: Cc:
CVSS Scoring: Parent Tickets:
Sensitive: no Defect Severity: Medium
Sub-Project: DNS Feature Depending on Ticket:
Estimated Difficulty: 0 Add Hours to Ticket: 0
Total Hours: 0 Internal?: no

Description

When adding a new zone we see this:

> config add Zonemgr/secondary_zones
> config show Zonemgr/secondary_zones
Zonemgr/secondary_zones[0]/class	"IN"	string	(modified)
Zonemgr/secondary_zones[0]/name	"time-travellers.nl.eu.org"	string	(modified)
Zonemgr/secondary_zones[1]/class	"IN"	string	(modified)
Zonemgr/secondary_zones[1]/name	"home.time-travellers.org"	string	(modified)
Zonemgr/secondary_zones[2]/class	"IN"	string	(default)
Zonemgr/secondary_zones[2]/name	""	string	(default)
> config set Zonemgr/secondary_zones[2]/name "example.com"
> config commit
Error: 'class'
Configuration not committed
> config set Zonemgr/secondary_zones[2]/class "IN"
> config commit
>

We should not have to set the class if we use the default.

Subtickets

Change History (2)

comment:1 Changed 8 years ago by jreed

Duplicate of #897 and #1414 (and #960)?

comment:2 Changed 8 years ago by shane

  • Milestone New Tasks deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Okay, #1414 is on next-sprint-proposed now. I'll close this as a duplicate.

Note: See TracTickets for help on using tickets.