Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#1421 closed defect (worksforme)

NOTIFY_OUT_DATASRC_ACCESS_FAILURE logged for every zone

Reported by: jreed Owned by: jreed
Priority: medium Milestone:
Component: data source Version:
Keywords: Cc:
CVSS Scoring: Parent Tickets:
Sensitive: no Defect Severity: High
Sub-Project: DNS Feature Depending on Ticket:
Estimated Difficulty: 0 Add Hours to Ticket: 0
Total Hours: 0 Internal?: no

Description

I have over a hundred log messages like:

2011-11-23 09:16:29.349 ERROR [b10-xfrout.notify_out] NOTIFY_OUT_DATASRC_ACCESS_FAILURE failed to get access to data source: Failed to create DataSourceClient of type sqlite3:Shared object "sqlite3_ds.so" not found

...

2011-11-23 09:16:29.657 ERROR [b10-xfrout.notify_out] NOTIFY_OUT_DATASRC_ACCESS_FAILURE failed to get access to data source: Failed to create DataSourceClient of type sqlite3:Shared object "sqlite3_ds.so" not found

One (I think) for every zone in my old sqlite3 database.

I think this is due to sqlite3 database change -- but error message is strange.

That shared object is in my install directory at ./lib/sqlite3_ds.so

Subtickets

Change History (5)

comment:1 Changed 8 years ago by jreed

Strange. I can not reproduce this.

comment:2 Changed 8 years ago by shane

  • Owner set to jreed
  • Status changed from new to assigned

So... what should we do with this ticket?

comment:3 Changed 8 years ago by jinmei

This is something that "should not happen" (TM) because we start
xfrout with specific LD_LIBRARY_PATH pointing to the place where
sqlite3_ds.so is installed. #1292 (when merged) will also change the
situation, hopefully even better.

My suggestion is to close the ticket for now.

comment:4 Changed 8 years ago by jreed

  • Resolution set to worksforme
  • Status changed from assigned to closed

Since I can't reproduce it, I will close now.

comment:5 Changed 8 years ago by shane

  • Milestone New Tasks deleted
Note: See TracTickets for help on using tickets.