Opened 8 years ago

Closed 8 years ago

#1363 closed defect (fixed)

Python wrapper build error with custom Boost path

Reported by: shane Owned by: UnAssigned
Priority: medium Milestone: Sprint-20111108
Component: build system Version:
Keywords: Cc:
CVSS Scoring: Parent Tickets:
Sensitive: no Defect Severity: Low
Sub-Project: DNS Feature Depending on Ticket:
Estimated Difficulty: 0 Add Hours to Ticket: 0
Total Hours: 0 Internal?: no

Description

I had a build error when trying to use a custom Boost path. This problem was introduced sometime since the last release (I used the same ./configure command with that and it worked).

The following patch fixes this.

shane@helium:~/src/bind10$ git diff
diff --git a/src/lib/python/isc/datasrc/Makefile.am b/src/lib/python/isc/datasrc
index 60282d9..a5b4ca3 100644
--- a/src/lib/python/isc/datasrc/Makefile.am
+++ b/src/lib/python/isc/datasrc/Makefile.am
@@ -8,6 +8,7 @@ python_PYTHON = __init__.py master.py sqlite3_ds.py
 # new data
 
 AM_CPPFLAGS = -I$(top_srcdir)/src/lib -I$(top_builddir)/src/lib
+AM_CPPFLAGS += $(BOOST_INCLUDES)
 AM_CPPFLAGS += $(SQLITE_CFLAGS)
 
 python_LTLIBRARIES = datasrc.la

Subtickets

Change History (2)

comment:1 Changed 8 years ago by shane

  • Status changed from new to reviewing

comment:2 Changed 8 years ago by jelte

  • Resolution set to fixed
  • Status changed from reviewing to closed

confirmed, committed, pushed.

Note: See TracTickets for help on using tickets.