Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#1318 closed defect (fixed)

ixfr/in-2 test needs use_ixfr enabled

Reported by: jreed Owned by: stephen
Priority: medium Milestone: Sprint-20111025
Component: xfrin Version:
Keywords: Cc:
CVSS Scoring: Parent Tickets:
Sensitive: no Defect Severity: N/A
Sub-Project: DNS Feature Depending on Ticket:
Estimated Difficulty: 1 Add Hours to Ticket: 0
Total Hours: 0 Internal?: no

Description

See http://git.bind10.isc.org/~tester/builder/BIND10-systest/20111018144505-MacOS/logs/systest.out

The logs only showed AXFR.

I looked at the tests/system/ixfr/bind10-config.db and see no IXFR enabled.

The man page documents the behaviour since last Wednesday:

use_ixfr (defaults to false)

Subtickets

Change History (7)

comment:1 Changed 8 years ago by jreed

This worked for me, but since this is the top-level configuration I don't know if this is correct for future tests. Could use bindctl to set it for in-2 specifically.

diff --git a/tests/system/ixfr/b10-config.db.in b/tests/system/ixfr/b10-config.d
index f83a672..946d80f 100644
--- a/tests/system/ixfr/b10-config.db.in
+++ b/tests/system/ixfr/b10-config.db.in
@@ -3,7 +3,8 @@
         "zones": [{
             "master_addr": "10.53.0.1",
             "master_port": 53210,
-            "name": "example."
+            "name": "example.",
+            "use_ixfr": true
         }]
     },
     "Auth": {

comment:2 Changed 8 years ago by stephen

  • Owner set to stephen
  • Status changed from new to assigned

comment:3 Changed 8 years ago by stephen

  • Milestone changed from New Tasks to Sprint-20111025
  • Owner changed from stephen to UnAssigned
  • Status changed from assigned to reviewing

Ticket #1213 (which introduced the bug) was based on the old configuration behaviour and missed the update that requires use of "use_ixfr" to enable IXFR.

This modification implements the patch to tests/system/ixfr/b10-config.db.in listed above.

...but since this is the top-level configuration I don't know if this is correct for future tests.

It is - all the test in the "ixfr" subdirectory are for IXFR, so "use_ixfr" should be set for all configurations. (Although, at the moment only the "in-2" tests are enabled.)

comment:4 Changed 8 years ago by vorner

  • Owner changed from UnAssigned to vorner

comment:5 Changed 8 years ago by vorner

  • Owner changed from vorner to stephen

Hello

I think it is OK to push.

However, I'm thinking it this is temporary, as we might want to default to using IXFR once the fallback is merged (#1279).

With regards

comment:6 Changed 8 years ago by stephen

  • Resolution set to fixed
  • Status changed from reviewing to closed

Merged into master in commit ae199c79e42520e8e521668c6f9435796ca92aa3

Last edited 8 years ago by stephen (previous) (diff)

comment:7 Changed 8 years ago by jelte

  • Estimated Difficulty changed from 0 to 1
Note: See TracTickets for help on using tickets.