Opened 8 years ago

Closed 8 years ago

#1295 closed task (fixed)

Kea: pack/unpack should use size_t instead of unsigned int

Reported by: tomek Owned by: UnAssigned
Priority: low Milestone: Sprint-DHCP-20120514
Component: dhcp Version:
Keywords: Cc:
CVSS Scoring: Parent Tickets:
Sensitive: no Defect Severity: Low
Sub-Project: DHCP Feature Depending on Ticket:
Estimated Difficulty: 1 Add Hours to Ticket: 0
Total Hours: 0 Internal?: no

Description (last modified by tomek)

In various places in code, pack()/unpack() and other methods specifying offsets should use size_t, rather than unsigned int. The same is true for pack4/pack6 and unpack4/unpack6 and related methods.

Subtickets

Change History (6)

comment:1 Changed 8 years ago by tomek

  • Estimated Difficulty changed from 0 to 1

comment:2 Changed 8 years ago by tomek

  • Description modified (diff)

comment:3 Changed 8 years ago by stephen

  • Milestone changed from DHCP 2012 to Sprint-DHCP-20120220

comment:4 Changed 8 years ago by tomek

  • Owner changed from UnAssigned to tomek
  • Status changed from new to accepted

comment:5 Changed 8 years ago by tomek

  • Owner changed from tomek to UnAssigned
  • Status changed from accepted to reviewing

Currently under review as part of #1540 ticket.

comment:6 Changed 8 years ago by tomek

  • Resolution set to fixed
  • Status changed from reviewing to closed

Most methods are void now. Methods that return length of consumed buffer now return size_t type.

Merged as part of #1540 work. Closing ticket.

Note: See TracTickets for help on using tickets.