Opened 8 years ago

Closed 5 years ago

#1270 closed defect (wontfix)

Failed to set up schema ... sqlite3.OperationalError: no such table: zones

Reported by: jreed Owned by:
Priority: medium Milestone: Remaining BIND10 tickets
Component: data source Version: bind10-old
Keywords: Cc:
CVSS Scoring: Parent Tickets:
Sensitive: no Defect Severity: N/A
Sub-Project: DNS Feature Depending on Ticket:
Estimated Difficulty: 0 Add Hours to Ticket: 0
Total Hours: 0 Internal?: no

Description

Note this was from running bind10 as installed using a FreeBSD ports package which was built with CONFIGURE_ARGS= --localstatedir=/var

Notice that the xfrout traceback got interspersed with real b10-auth logging output:

2011-09-29 15:34:59.696 ERROR [b10-auth.auth] AUTH_CONFIG_UPDATE_FAIL update of configuration failed: Failed to set up schema CREATE TABLE zones (id INTEGER PRIMARY KEY, name STRING NOT NULL COLLATE NOCASE, rdclass STRING NOT NULL COLLATE NOCASE DEFAULT 'IN', dnssec BOOLEAN NOT NULL DEFAULT 0)
Traceback (most recent call last):
  File "/usr/local/libexec/bind10-devel/b10-xfrout", line 723, in <module>
    xfrout_server = XfroutServer()
  File "/usr/local/libexec/bind10-devel/b10-xfrout", line 616, in __init__
    self._start_notifier()
  File "/usr/local/libexec/bind10-devel/b10-xfrout", line 628, in _start_notifier
    self._notifier = notify_out.NotifyOut(datasrc)
  File "/usr/local/lib/python3.1/site-packages/isc/notify/notify_out.py", line 120, in __init__
2011-09-29 15:34:59.731 INFO  [b10-auth.auth] AUTH_SERVER_STARTED server started
    self._init_notify_out(datasrc_file)
  File "/usr/local/lib/python3.1/site-packages/isc/notify/notify_out.py", line 132, in _init_notify_out
    for zone_name, zone_class in sqlite3_ds.get_zones_info(datasrc_file):
  File "/usr/local/lib/python3.1/site-packages/isc/datasrc/sqlite3_ds.py", line 161, in get_zones_info
    cur.execute("SELECT name, rdclass FROM zones")
sqlite3.OperationalError: no such table: zones

sqlite3 shows:

freebsd8-64-4# sqlite3 /var/bind10-devel/zone.sqlite3
SQLite version 3.7.4
Enter ".help" for instructions
Enter SQL statements terminated with a ";"
sqlite> .tables
schema_version

Maybe different components are using different path to the database?

Some suggestions:

  • log output give more information like the path to the database.
  • sqlite3_ds.py check before using
  • xfrout fail cleanly on failures (no traceback)

The problem is in both components.

Subtickets

Change History (5)

comment:1 Changed 8 years ago by jreed

Now with DEBUG 99:

2011-09-29 15:38:58.105 DEBUG [b10-auth.auth] AUTH_DATA_SOURCE data source database file: /var/bind10-devel/zone.sqlite3
2011-09-29 15:38:58.106 DEBUG [b10-auth.datasrc] DATASRC_SQLITE_CREATE SQLite data source created
2011-09-29 15:38:58.107 DEBUG [b10-auth.datasrc] DATASRC_SQLITE_OPEN opening SQLite database '/var/bind10-devel/zone.sqlite3'
2011-09-29 15:38:58.112 DEBUG [b10-auth.datasrc] DATASRC_SQLITE_DESTROY SQLite data source destroyed
2011-09-29 15:38:58.114 ERROR [b10-auth.auth] AUTH_CONFIG_UPDATE_FAIL update of configuration failed: Could not prepare SQLite statement: SELECT id FROM zones WHERE name=?1

I moved the existing database out of the way.

I was able to repeat this problem multiple times. But now I also was able to run it without seeing the error.

comment:2 Changed 8 years ago by shane

  • Milestone changed from New Tasks to Next-Sprint-Proposed

comment:3 Changed 8 years ago by jelte

  • Milestone changed from Next-Sprint-Proposed to Year 3 Task Backlog

comment:4 Changed 6 years ago by tomek

  • Milestone set to Remaining BIND10 tickets

comment:5 Changed 5 years ago by tomek

  • Resolution set to wontfix
  • Status changed from new to closed
  • Version set to old-bind10

This issue is related to bind10 code that is no longer part of Kea.

If you are interested in BIND10/Bundy framework or its DNS components,
please check http://bundy-dns.de.

Closing ticket.

Note: See TracTickets for help on using tickets.