Opened 8 years ago

Closed 8 years ago

#1220 closed defect (fixed)

strange bindctl config show output

Reported by: jreed Owned by: muks
Priority: low Milestone: Sprint-20120403
Component: ~bind-ctl (obsolete) Version:
Keywords: Cc:
CVSS Scoring: Parent Tickets:
Sensitive: no Defect Severity: Low
Sub-Project: Core Feature Depending on Ticket:
Estimated Difficulty: 4 Add Hours to Ticket: 0
Total Hours: 0 Internal?: no

Description

> config show Resolver/listen_on/
Error: Resolver/listen_on/[0]/address not found
> config show Resolver/listen_on 
Resolver/listen_on[0]/address   "::1"   string
Resolver/listen_on[0]/port      53      integer

That first attempt's response is confusing.

Subtickets

Change History (12)

comment:1 Changed 8 years ago by shane

  • Milestone changed from New Tasks to Year 3 Task Backlog

comment:2 Changed 8 years ago by jelte

  • Milestone changed from Year 3 Task Backlog to Next-Sprint-Proposed

comment:3 Changed 8 years ago by jelte

not sure if this is still an issue; if i try to reproduce this i get expected results now:

> config show Resolver/listen_on
Resolver/listen_on[0]/address	"::1"	string	
Resolver/listen_on[0]/port	5300	integer	
> config show Resolver/listen_on/
Resolver/listen_on[0]/address	"::1"	string	
Resolver/listen_on[0]/port	5300	integer	

Could this have been fixed by one of the list addressing tickets we have done already?

comment:4 Changed 8 years ago by jelte

  • Estimated Difficulty changed from 0 to 4

comment:5 Changed 8 years ago by jelte

  • Milestone changed from Next-Sprint-Proposed to Sprint-20120403

comment:6 Changed 8 years ago by muks

Picking bug.

I am not able to reproduce this issue, and going through log did not turn up any obvious related changes. Will look and see what happened anyway.

comment:7 Changed 8 years ago by muks

  • Owner set to muks
  • Status changed from new to assigned

comment:8 Changed 8 years ago by muks

  • Owner changed from muks to UnAssigned
  • Status changed from assigned to reviewing

This bug was fixed by commit b31b7eff36397f30f00d7c31805bf7634395dfa8 made as a part of bug #1649. That bug also added a testcase.

However, I have added another testcase which checks for trailing slash with indices. This is in branch trac1220. It's up for review.

comment:9 Changed 8 years ago by jelte

  • Owner changed from UnAssigned to muks

seems fine :)

perhaps we can also add the same without the list index (to test whether the / is ignored if you ask it for the whole list Spec22/value5 and Spec22/value5/)

comment:10 Changed 8 years ago by muks

  • Owner changed from muks to jelte

You already added that test I think :) (a few lines above this testcase)

comment:11 Changed 8 years ago by jelte

  • Owner changed from jelte to muks

how preemptive of me :)

OK, please merge

comment:12 Changed 8 years ago by muks

  • Resolution set to fixed
  • Status changed from reviewing to closed

Pushed to master:

* 365b5c4 [1220] Add testcase which checks use of trailing slashes with indices

Resolving bug.

Note: See TracTickets for help on using tickets.