Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#1200 closed defect (duplicate)

botan-config version 1.10not found

Reported by: cas Owned by: UnAssigned
Priority: medium Milestone:
Component: build system Version:
Keywords: Cc:
CVSS Scoring: Parent Tickets:
Sensitive: no Defect Severity: N/A
Sub-Project: Core Feature Depending on Ticket:
Estimated Difficulty: 0 Add Hours to Ticket: 0
Total Hours: 0 Internal?: no

Description

on MacOS X 10.4 PPC (might appear on other platforms as well), the BIND 10 configure script (version 20110819) does not find the installed Botan library (version 1.10)

./configure --with-botan=/usr/local/
[...]
checking whether g++ supports -Wno-missing-field-initializers... yes
checking for in-TU anonymous namespace breakage... no
checking whether we need -Wno-unused-parameter for python... no
checking for library containing inet_pton... none required
checking for library containing recvfrom... none required
checking for library containing nanosleep... none required
checking for stdbool.h that conforms to C99... yes
checking for _Bool... no
checking for size_t... yes
checking for sa_len in struct sockaddr... yes
configure: error: /usr/localbin/botan-config not found

Botan 1.10 installs this file:
imachome% /usr/local/bin/botan-config-1.10

header files are in /usr/local/include/botan-1.10/botan/

this line solves the problem
sudo ln -s /usr/local/bin/botan-config-1.10 /usr/local/bin/botan-config
sudo ln -s /usr/local/include/botan-1.10/botan /usr/local/include/botan

but is not the recommended way, I guess :)

Subtickets

Change History (2)

comment:1 Changed 8 years ago by vorner

  • Resolution set to duplicate
  • Status changed from new to closed

Thanks for reporting it, but this one is already known. It is in #1194.

comment:2 Changed 8 years ago by shane

  • Milestone New Tasks deleted
Note: See TracTickets for help on using tickets.