Opened 10 years ago

Closed 8 years ago

Last modified 8 years ago

#110 closed defect (worksforme)

bind10 should always exit safely, even on bad startup

Reported by: jreed Owned by:
Priority: medium Milestone:
Component: ~Boss of BIND (obsolete) Version:
Keywords: Cc:
CVSS Scoring: Parent Tickets:
Sensitive: no Defect Severity: N/A
Sub-Project: DNS Feature Depending on Ticket:
Estimated Difficulty: 0.0 Add Hours to Ticket:
Total Hours: Internal?: no

Description

I pressed ctrl-c while msgq was getting started.
Next attempt to start bind10 failed as the previous msgq actually was running.

Subtickets

Change History (5)

comment:1 Changed 9 years ago by shane

  • Component changed from Unclassified to Boss of BIND
  • Milestone set to feature backlog item

comment:2 Changed 9 years ago by vorner

  • billable set to 0
  • Estimated Difficulty set to 0.0
  • Internal? unset

Could you have a look at the branches/trac300 if it is solved there? Every process there is added to a list and if the startup fails, all processes are killed. The old code didn't catch all exceptions (like KeyboardInterrupt?) and had long windows that didn't catch anything.

In theory, there's a short window where the process can survive ‒ if you send the signal between the fork call and the place where the process is added to the list (which is the next line of code). It should be short and I do not see an easy way to solve it, do you think this is OK?

comment:3 Changed 9 years ago by stephen

  • Milestone feature backlog item deleted

Milestone feature backlog item deleted

comment:4 Changed 8 years ago by shane

  • Defect Severity set to N/A
  • Milestone set to New Tasks
  • Resolution set to worksforme
  • Status changed from new to closed
  • Sub-Project set to DNS

I couldn't reproduce this with a modern BIND 10. Resolving ticket.

comment:5 Changed 8 years ago by shane

  • Milestone New Tasks deleted
Note: See TracTickets for help on using tickets.