Opened 10 years ago

Closed 9 years ago

Last modified 9 years ago

#108 closed defect (fixed)

--with-boostlib should fail if missing

Reported by: jreed Owned by: jreed
Priority: medium Milestone:
Component: Unclassified Version:
Keywords: Cc:
CVSS Scoring: Parent Tickets:
Sensitive: no Defect Severity:
Sub-Project: Feature Depending on Ticket:
Estimated Difficulty: 0.0 Add Hours to Ticket:
Total Hours: Internal?: no

Description (last modified by shane)

If admin chooses to use --with-boost-lib and it doesn't find the support, configure should not continue.

Subtickets

Change History (8)

comment:1 Changed 10 years ago by jreed

Problem still exists. Now the option is called --with-boost-lib.

comment:2 Changed 10 years ago by jreed

I can fix this but want to know if anyone has any opinions on this.

comment:3 Changed 10 years ago by shane

  • Description modified (diff)

comment:4 Changed 10 years ago by shane

  • Owner set to jreed
  • Status changed from new to assigned

Yes it should fail. <captain hair="bald">Make it so!</captain>

comment:5 Changed 10 years ago by shane

  • Milestone changed from 02. Running, functional authoritative-only server to feature backlog item

Moving to backlog.

comment:6 Changed 10 years ago by each

I think this ticket will be moot after #168 is merged; as far as I know, --with-boostlib is only needed for boost::asio, and after that's gone we can get rid of it.

comment:7 Changed 9 years ago by jreed

  • billable set to 0
  • Estimated Difficulty set to 0.0
  • Internal? unset
  • Resolution set to fixed
  • Status changed from assigned to closed

I removed --with-boost-lib from configure.ac, so closing this ticket.

comment:8 Changed 9 years ago by stephen

  • Milestone feature backlog item deleted

Milestone feature backlog item deleted

Note: See TracTickets for help on using tickets.