Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#1050 closed defect (duplicate)

traceback in xfrout when Ctrl-C in boss

Reported by: jreed Owned by:
Priority: medium Milestone:
Component: Unclassified Version:
Keywords: Cc:
CVSS Scoring: Parent Tickets:
Sensitive: no Defect Severity: N/A
Sub-Project: DNS Feature Depending on Ticket:
Estimated Difficulty: 0.0 Add Hours to Ticket: 0
Total Hours: 0 Internal?: no

Description

Similar to #1048.

I pressed Ctrl-C and got this noisy output:

^C[bind10] Received SIGINT.
[bind10] Stopping the server.
[b10-msgq] Closing socket fd 5
[b10-msgq] Receive error: EOF
[b10-auth] Received 'shutdown' command
[b10-msgq] Closing socket fd 9
[b10-msgq] Receive error: EOF
[b10-msgq] Closing socket fd 8
[b10-msgq] Receive error: EOF
[b10-msgq] Closing socket fd 7
[b10-msgq] Receive error: EOF
2011-06-23 13:41:17.496 DEBUG [b10-auth.datasrc] DATASRC_CACHE_DESTROY destroying the hotspot cache
[bind10] Sending SIGTERM to b10-zonemgr (PID 48389).
[bind10] Sending SIGTERM to b10-stats (PID 48396).
[bind10] Sending SIGTERM to b10-stats-httpd (PID 48397).
[bind10] Sending SIGTERM to b10-cmdctl (PID 48398).
[bind10] Sending SIGTERM to b10-msgq (PID 48370).
[bind10] Sending SIGTERM to b10-xfrout (PID 48377).
[bind10] Sending SIGTERM to b10-xfrin (PID 48383).
Exception AttributeError: "'ModuleCCSession' object has no attribute '_session'" in <bound method ModuleCCSession.__del__ of <isc.config.ccsession.ModuleCCSession object at 0x802776c10>> ignored
Traceback (most recent call last):
  File "/usr/home/jreed/builder/work/BIND10-cppcheck/20110623093001-FreeBSD8-amd64-GCC/build/src/bin/xfrout/b10-xfrout", line 676, in <module>
    xfrout_server = XfroutServer()
  File "/usr/home/jreed/builder/work/BIND10-cppcheck/20110623093001-FreeBSD8-amd64-GCC/build/src/bin/xfrout/b10-xfrout", line 564, in __init__
    self._cc.start()
  File "/usr/home/jreed/builder/work/BIND10-cppcheck/20110623093001-FreeBSD8-amd64-GCC/build/src/lib/python/isc/config/ccsession.py", line 186, in start
    self.__send_spec()
  File "/usr/home/jreed/builder/work/BIND10-cppcheck/20110623093001-FreeBSD8-amd64-GCC/build/src/lib/python/isc/config/ccsession.py", line 344, in __send_spec
    seq = self._session.group_sendmsg(msg, "ConfigManager")
[bind10] Sending SIGKILL to b10-xfrout (PID 48377).
[bind10] Sending SIGKILL to b10-xfrin (PID 48383).
[bind10] All processes ended, server done.
[bind10] BIND 10 exiting


Subtickets

Change History (2)

comment:1 Changed 8 years ago by shane

  • Resolution set to duplicate
  • Status changed from new to closed

I think this is basically a duplicate of #1048.

comment:2 Changed 8 years ago by shane

  • Milestone New Tasks deleted
Note: See TracTickets for help on using tickets.