Opened 8 years ago

Closed 8 years ago

#1048 closed defect (wontfix)

traceback in zonemgr when Ctrl-C in bind10

Reported by: jreed Owned by:
Priority: medium Milestone: Year 3 Task Backlog
Component: ~Boss of BIND (obsolete) Version:
Keywords: Cc:
CVSS Scoring: Parent Tickets:
Sensitive: no Defect Severity: Medium
Sub-Project: DNS Feature Depending on Ticket:
Estimated Difficulty: 0.0 Add Hours to Ticket: 0
Total Hours: 0 Internal?: no

Description

I received the following traceback in zonemgr when pressed Ctrl-C in bind10:

^C[bind10] Received SIGINT.
[bind10] Stopping the server.
[b10-auth] Received '[b10-msgq] Closing socket fd 6
[b10-msgq] Receive error: EOF
shutdown' command
[b10-msgq] Closing socket fd 9
[b10-msgq] Receive error: EOF
[b10-msgq] Closing socket fd 8
[b10-msgq] Receive error: EOF
[b10-msgq] Closing socket fd 7
[b10-msgq] Receive error: EOF
2011-06-23 13:32:41.427 DEBUG [b10-auth.datasrc] DATASRC_CACHE_DESTROY destroying the hotspot cache
[bind10] Sending SIGTERM to b10-stats-httpd (PID 28641).
[bind10] Sending SIGTERM to b10-msgq (PID 28358).
[bind10] Sending SIGTERM to b10-xfrout (PID 28617).
[bind10] Sending SIGTERM to b10-xfrin (PID 28630).
[bind10] Sending SIGTERM to b10-cmdctl (PID 28644).
[bind10] Sending SIGTERM to b10-zonemgr (PID 28637).
[bind10] Sending SIGTERM to b10-stats (PID 28639).
[b10-xfrout] Error creating xfrout, is the command channel daemon running?
Exception AttributeError: "'ModuleCCSession' object has no attribute '_session'" in <bound method ModuleCCSession.__del__ of <isc.config.ccsession.ModuleCCSession object at 0x8027706d0>> ignored
Traceback (most recent call last):
  File "/usr/home/jreed/builder/work/BIND10-cppcheck/20110623093001-FreeBSD8-amd64-GCC/build/src/bin/zonemgr/b10-zonemgr", line 648, in <module>
    zonemgrd = Zonemgr()
  File "/usr/home/jreed/builder/work/BIND10-cppcheck/20110623093001-FreeBSD8-amd64-GCC/build/src/bin/zonemgr/b10-zonemgr", line 484, in __init__
[bind10] Sending SIGKILL to b10-msgq (PID 28358).
[bind10] Sending SIGKILL to b10-xfrout (PID 28617).
[bind10] Sending SIGKILL to b10-zonemgr (PID 28637).
[bind10] Sending SIGKILL to b10-stats (PID 28639).
[bind10] All processes ended, server done.
[bind10] BIND 10 exiting

Some how shutdown ordering is wrong? Or too slow?

zonemgr should not have a noisy shutdown.

I am opening a different ticket about the SIGKILLs.

Subtickets

Change History (3)

comment:1 Changed 8 years ago by shane

It looks like none of the Python programs got a shutdown command for some reason.

comment:2 Changed 8 years ago by shane

  • Component changed from Unclassified to Boss of BIND
  • Defect Severity changed from N/A to Medium
  • Milestone changed from New Tasks to Year 3 Task Backlog

comment:3 Changed 8 years ago by shane

  • Resolution set to wontfix
  • Status changed from new to closed

I don't think the main problem - the children not getting the shutdown command - has been solved. OTOH the software is all different now, and I suspect the problem is in the msgq itself.

Closing and we can re-open (or make a new ticket) as necessary.

Note: See TracTickets for help on using tickets.