Opened 9 years ago

Closed 8 years ago

#1045 closed defect (wontfix)

'make DESTDIR=../DEST install' fails

Reported by: cas Owned by: jelte
Priority: medium Milestone: Year 3 Task Backlog
Component: build system Version:
Keywords: Cc:
CVSS Scoring: Parent Tickets:
Sensitive: no Defect Severity: Medium
Sub-Project: Core Feature Depending on Ticket:
Estimated Difficulty: 5.0 Add Hours to Ticket: 0
Total Hours: 0 Internal?: no

Description

Version: bind10-devel-20110519
OS: Darwin 10.7.0 Darwin Kernel Version 10.7.0: Sat Jan 29 15:17:16 PST 2011; root:xnu-1504.9.37~1/RELEASE_I386 i386

installing BIND 10 in a dedicated installation directory for packaging does fail if the target directory is given relative to the build directory:

bind10-devel-20110519 # make DESTDIR=../DEST install
Making install in doc
Making install in guide
make[3]: Nothing to be done for `install-exec-am'.
make[3]: Nothing to be done for `install-data-am'.
make[3]: Nothing to be done for `install-exec-am'.
make[3]: Nothing to be done for `install-data-am'.
Making install in src
Making install in lib
Making install in exceptions
Making install in .
test -z "/usr/local/lib" || /opt/local/bin/gmkdir -p "../DEST/usr/local/lib"
 /bin/sh ../../../libtool   --mode=install /usr/bin/install -c   libexceptions.la '../DEST/usr/local/lib'
libtool: install: `../DEST/usr/local/lib' must be an absolute directory name
libtool: install: Try `libtool --help --mode=install' for more information.
make[5]: *** [install-libLTLIBRARIES] Error 1
make[4]: *** [install-am] Error 2
make[3]: *** [install-recursive] Error 1
make[2]: *** [install-recursive] Error 1
make[1]: *** [install-recursive] Error 1
make: *** [install-recursive] Error 1

Subtickets

Change History (10)

comment:1 Changed 9 years ago by shane

  • Defect Severity changed from N/A to Medium
  • Milestone changed from New Tasks to Next-Sprint-Proposed

comment:2 Changed 9 years ago by jinmei

I'm not sure if we want to address it.

It looks like a restriction of autotools. We can blame the tool, but overall it's a tradeoff
between reducing in-house overhead for common cases and having full control and giving
more flexibility. If we want to revisit the use of autotools at this higher level, that's fine,
but otherwise I believe we should live with the restriction of the given tools.

comment:3 Changed 9 years ago by stephen

  • Estimated Difficulty changed from 0.0 to 5

comment:4 Changed 9 years ago by cas

We @ Men & Mice are building binary installation packages for multiple DNS related products (BIND 9, Unbound, libdns, NSD, rdnssd) for different operating systems (Solaris 10, Redhat Linux, Debian Linux, MacOS X, KGNU/Freebsd, Nexenta ...).

We would like to start to do the same for BIND 10.

The packages are publicly available for no charge.

To my knowledge all of the tools above use autotools, and during the package building process we always do a 'make DESTDIR=../DEST install' relative to the build directory. It works for all of the software packages above, so I do not think it is a general restriction of autotools.

comment:5 Changed 9 years ago by stephen

  • Milestone changed from Next-Sprint-Proposed to Sprint-20110816

comment:6 Changed 9 years ago by jinmei

  • Owner changed from jreed to UnAssigned
  • Status changed from new to assigned

comment:7 Changed 9 years ago by jelte

Could this be a recent restriction? I've tried it with bind9, ldns and unbound, and the last two fail with the same error. Bind9 does not, I would guess because it doesn't use automake nor libtool.

comment:8 Changed 8 years ago by jelte

  • Milestone changed from Sprint-20110927 to Sprint-20111011

comment:9 Changed 8 years ago by jelte

  • Milestone changed from Sprint-20111011 to Year 3 Task Backlog
  • Owner changed from UnAssigned to jelte

assigning it to me to remind me i need to contact carsten about this

comment:10 Changed 8 years ago by jelte

  • Resolution set to wontfix
  • Status changed from assigned to closed

Had a very short offline discussion about this with the submitter. This is something caused or restricted by the tool suite; the workaround is to use $pwd in the command-line.

Closing this ticket.

Note: See TracTickets for help on using tickets.