Opened 9 years ago

Closed 9 years ago

Last modified 9 years ago

#1020 closed task (complete)

run systest on buildbot

Reported by: jinmei Owned by: UnAssigned
Priority: medium Milestone: Sprint-20110816
Component: build system Version:
Keywords: Cc:
CVSS Scoring: Parent Tickets:
Sensitive: no Defect Severity: N/A
Sub-Project: Core Feature Depending on Ticket:
Estimated Difficulty: 4.0 Add Hours to Ticket: 0
Total Hours: 0 Internal?: no

Description

(IMO) We've seen sufficient number of run time regression that
cannot be caught via unittests.

I now strongly suggest we run systest (make systest) on some of our
buildbots even if it required some ugly quick hack.

Subtickets

Change History (5)

comment:1 Changed 9 years ago by jinmei

  • Owner changed from jreed to UnAssigned
  • Status changed from new to assigned

comment:2 Changed 9 years ago by stephen

  • Estimated Difficulty changed from 0.0 to 4

comment:3 Changed 9 years ago by jreed

  • Type changed from defect to task

Just a status update: my build framework creates unique directory names that are currently too long for the socket length limits. See ticket #360. I tried to workaround this with shorter symlinks but that failed -- something in our code replaced the path with the target path. There are environment variables and command line switches to choose the msqg and/or xfrout socket paths, but those are overridden or ignored due to other environment variable settings as used by systest target and the run_build.sh. (That is a problem that needs to be fixed!) As a workaround I have been patching the systest run? script to choose a different msgq socket path.

So my next step is to change my build framework so I can override the path that the builds or installs are done in.

Changed this from defect to a task.

comment:4 Changed 9 years ago by jreed

  • Resolution set to complete
  • Status changed from assigned to closed

This has been running for over a week. http://git.bind10.isc.org/~tester/builder/builder.html
(I realize I need to automate the generation of webpages per build system so I could link to that instead.)

Closing ticket.

comment:5 Changed 9 years ago by shane

  • Milestone changed from Next-Sprint-Proposed to Sprint-20110816
Note: See TracTickets for help on using tickets.